Hard Drive Mapped Twice on Windows Image made from Dell OS Media

Hello Experts,

I've got an interesting situation I'm trying to work out.
I recently made a deployable Windows 7 pro system image using WinPE, Sysprep, and Answer files.  Everything has worked as expected but I'm running into one problem.  Once the system is deployed, the main hard drive maps itself twice, once as C: and once as Z:.  They are not separate partitions, and both point to the same directories and files.

Z: does not show up as a drive in disk manager, and can be removed with CMD tools, but usually reappears on a reboot.  The problem is that User's folders are mapped to Z: through GPO, so I can't have this ghost drive showing up and intruding.  

I've had this problem once before on a system installed from scratch using Dell re-installation media so I'm thinking that is related to the problem.  I've noticed that the system keeps the Dell theme as the default even when a new default profile is created, so perhaps there are some hidden policies or scripts running that are trying to map Dell recovery partitions or keep the system as "Dell-like" as possible.  Also, it seems to be hardware non-dependent, showing up on several different models of system.

Hopefully I've given you all information you'll need.  Let me know if you have any questions.

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rob MinersCommented:
Drop to a command prompt and type in subst

if you see something similar to this Z:\: => D:\alltext

type in subst Z: /d
ravib123Author Commented:
I've used this approach before but it seems to me that the drive re-maps itself on reboot, so this is not a permanent solution.  In one case, the re-map was not right away, but it did eventually re-occur.  

I can try this when I again have access to the solution, but I need to know how to prevent this from occurring at all either in my master image or once the system is deployed.
Rob MinersCommented:
check out ManiacMan's suggestions for removing phantom drives

Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

Rob MinersCommented:
Also check out this Registry setting and if it exists delete the Z key

ravib123Author Commented:

Thanks for all of the input so far.  I was able to sit back down with a deployed system again this morning and I've tried all of these suggestions and various combinations therof.  So far nothing works past a reboot.  Every time I restart the computer the hard drive is again mapped to both C: and Z:  

...Any other thoughts?
ravib123Author Commented:
Another update:

I joined the system to the domain, and then cleared the Z: drive with subst.  After that, I mapped two network folders, one of which is mapped to Z:.  After a restarted, the hard drive is now being mapped to C: and Y:.

This is certainly strange behavior...  It sounds very similar to the situation posted by ManiacMan but is with a local drive, not a network drive.
Rob MinersCommented:
Dell are propriatory Systems and arn't designed to be manipulated as they have already been manipulated to suit the environment that they have been designed for. Maybe you should consider looking at Windows 7 Enterprise. You could then use that media to create your deployment solution. That way you will have complete control of the environment.

ravib123Author Commented:
Well, since no one was able to provide me an answer, and instead decided to write it off as a Dell problem, I thought I would post the actual solution.


The latest version of Uniprint causes the drive mapping problem.
I created a new image, and installed software one by one until the problem appeared.

Reference this link for a similar situation with the same solution.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ravib123Author Commented:
Here is the solution, as listed in that post

"to stop the automatic mapping we had to add "DriveMapping"="0" into [HKEY_CURRENT_USER\Software\UniPrint\Client"

Much Credit to user Windos at SuperUser.com
ravib123Author Commented:
No one was able to provide a real solution and I poured many more hours into testing and research until I found a solution that worked.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.