Solved

Cisco ASA 5505 8,4 - No internet / traffic

Posted on 2012-03-30
11
773 Views
Last Modified: 2012-04-13
We are currently having issues implementing a new Cisco ASA 5505 device into our network.  We are replacing an older Juniper router and pretty much copied all the IP information and configured it into the new ASA.  It will be running as a normal VPN/Firewall as well as DHCP server; however we are unable to get any internal computers from getting internet access.  Computers are getting IP's correctly; however unable to get internet access.  Please see my running config below and any help would be appreciated.


ASA Version 8.4(2)
!
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 205.x.x.240 255.255.255.0
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 20.x.x.25
 name-server 20.x.x.26
same-security-traffic permit intra-interface
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network SBS_2003
 host 192.168.2.49
object network NETWORK_OBJ_192.168.2.0_24
 subnet 192.168.2.0 255.255.255.0
object network NETWORK_OBJ_192.168.5.192_27
 subnet 192.168.5.192 255.255.255.224
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list outside_access_in extended permit tcp any interface outside eq https
access-list outside_access_in extended permit icmp any interface outside
access-list name_splitTunnelAcl standard permit 192.168.2.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPN_Users 192.168.10.194-192.168.10.220 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (inside,outside) source static NETWORK_OBJ_192.168.2.0_24 NETWORK_OBJ_192.168.2.0_24 destination static NETWORK_OBJ_192.168.10.192_27 NETWORK_OBJ_192.168.10.192_27 no-proxy-arp route-lookup
!
object network obj_any
 nat (inside,outside) dynamic interface
object network SBS_2003
 nat (inside,outside) static interface service tcp smtp smtp
!
nat (inside,outside) after-auto source dynamic any interface
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 177.x.x.239 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.2.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 192.168.2.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0

dhcpd address 192.168.2.160-192.168.2.199 inside
dhcpd dns 192.168.2.49 24.29.99.36 interface inside
dhcpd wins 192.168.2.49 24.29.99.36 interface inside
dhcpd domain name interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy name internal
group-policy name attributes
 wins-server value 192.168.2.49
 dns-server value 192.168.2.49
 vpn-tunnel-protocol ikev1
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value name_splitTunnelAcl
 default-domain value name.local
username ben password zWCAaitV3CB.GA87 encrypted privilege 0
username ben attributes
 vpn-group-policy name
username joe password O72LiZyIktgAjNrI encrypted privilege 0
username joe attributes
 vpn-group-policy name
tunnel-group name type remote-access
tunnel-group name general-attributes
 address-pool VPN_Users
 default-group-policy name
tunnel-group name ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:620e61ec5a64f9c3bdbcd70da69f53b6
: end
no asdm history enable
0
Comment
Question by:bns-nyc
  • 7
  • 3
11 Comments
 
LVL 10

Expert Comment

by:pclinuxguru
ID: 37789028
What looks odd is 177.x.x.239 in your route.
route outside 0.0.0.0 0.0.0.0 177.x.x.239 1

what happens when you "ping outside 177.x.x.239"

Reason it looks odd is that it is not on the same network as your outside interface:
 ip address 205.x.x.240 255.255.255.0
0
 

Author Comment

by:bns-nyc
ID: 37789130
Thanks for the response Pclinuxguru.  Actually I just noticed that I mistakenly copy and pasted the wrong address into the Route Outside when I posted this (was looking at a different IP from different log).

The Route Outside 0.0.0.0 0.0.0.0 205.x.x.240 1  is indeed how the ASA is currently setup and apologies for the confusion.  Any other suggestions?  I've looked at this config over and over again but still no idea what could be preventing any outside / internet access. Thanks
0
 
LVL 10

Expert Comment

by:pclinuxguru
ID: 37789188
Well you can do a few things.

1) What are the results of "show interface outside" (you can xxx out any ip's)
2) Are you able to "ping outside 205.x.x.240"
3) If yes to 2 can you "ping outside 8.8.8.8"?
0
 
LVL 17

Expert Comment

by:lruiz52
ID: 37789839
Try below;

Config t
object network obj_any
no nat (inside,outside) dynamic interface
exit
nat (inside,outside) source dynamic obj_any
0
 

Author Comment

by:bns-nyc
ID: 37791642
- pclinuxguru,  thanks for the response.  I wasn't able to check these before I left work Friday, but do remember a few things.
1.  Wasn't able to run
2. Was able to ping outside, but from only the sbs server on the network.  No client computers were able to ping outside at all.  The sbs server was able to get internet access, but no client machines for some reason. The sbs server has a static internal ip setup, while client computers were dhcp from ASA.
3.  Again, was able to ping 4.2.2.2 from only sbs sever, but no client computers.


- Iruiz52, thanks for the command. Will definitely give that a try when I get back into the office next week.. Looks like this command will remove all the current NAT settings I take it?
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 10

Expert Comment

by:pclinuxguru
ID: 37796489
What do you mean by "wasn't able to run"?
Did it return an error?
0
 

Author Comment

by:bns-nyc
ID: 37797043
Pclinixguru;   i meant that i forgot to  run that command to try and troubleshoot Friday, when I was last in the office.  I actually wont be back in the office till tomorrow (Tues) and will give that command a try though, and provide results for you.  Thanks again for your help.

EDIT:  here is the results of the command you requested, along with results of pinging the outside interfaces as well as default gateway (TimeWarner ISP modem)

Result of the command: "show interface outside"

Interface Vlan2 "outside", is up, line protocol is up
  Hardware is EtherSVI, BW 100 Mbps, DLY 100 usec
      MAC address 649e.f3b7.12a3, MTU 1500
      IP address 205.x.x.240, subnet mask 255.255.255.0
  Traffic Statistics for "outside":
      8 packets input, 368 bytes
      685 packets output, 45501 bytes
      0 packets dropped
      1 minute input rate 0 pkts/sec,  1 bytes/sec
      1 minute output rate 2 pkts/sec,  190 bytes/sec
      1 minute drop rate, 0 pkts/sec
      5 minute input rate 0 pkts/sec,  1 bytes/sec
      5 minute output rate 2 pkts/sec,  140 bytes/sec
      5 minute drop rate, 0 pkts/sec



Result of the command: "show interface inside"

Interface Vlan1 "inside", is up, line protocol is up
  Hardware is EtherSVI, BW 100 Mbps, DLY 100 usec
      MAC address 649e.f3b7.12a3, MTU 1500
      IP address 192.168.2.1, subnet mask 255.255.255.0
  Traffic Statistics for "inside":
      1949 packets input, 154826 bytes
      837 packets output, 143021 bytes
      667 packets dropped
      1 minute input rate 13 pkts/sec,  1008 bytes/sec
      1 minute output rate 12 pkts/sec,  1759 bytes/sec
      1 minute drop rate, 2 pkts/sec
      5 minute input rate 5 pkts/sec,  460 bytes/sec
      5 minute output rate 2 pkts/sec,  363 bytes/sec
      5 minute drop rate, 1 pkts/sec



Result of the command: "ping 205.x.x.240"  (OUTSIDE INTERFACE)

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 205.x.x.240, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms



Result of the command: "ping 205.X.X.249"  (DEFAULT GATEWAY)

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 208.105.3.249, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
0
 

Author Comment

by:bns-nyc
ID: 37802883
- Iruiz52, I tried running your commands as well as got as far as:
Config t
object network obj_any

However, once I got to: no nat (inside,outside) dynamic interface, it kept prompting me with an error.  Is there another syntax or command to use for my ASA version?
0
 

Author Comment

by:bns-nyc
ID: 37806992
Hi, to further go on this, I have pasted below a copy of my latest and cleaner Running Config.  Directly underneath that, I have also pasted a copy of the info that our ISP provided us, in hopes someone is able to figure out what the issue may be.  Thanks again for your help.


-  RUNNING CONFIG

: Saved
:
ASA Version 8.4(2)
!
hostname asa
enable password pqF5Xohw. encrypted
passwd NIdI.2KYOU encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 208.x.x.250 255.255.255.248
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
same-security-traffic permit intra-interface
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network SBS_2003
 host 192.168.2.49
object network NETWORK_OBJ_192.168.2.0_24
 subnet 192.168.2.0 255.255.255.0
object network NETWORK_OBJ_192.168.5.192_27
 subnet 192.168.5.192 255.255.255.224
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list outside_access_in extended permit tcp any interface outside eq https
access-list outside_access_in extended permit icmp any interface outside
access-list Scordio_splitTunnelAcl standard permit 192.168.2.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPN_Users 192.168.5.194-192.168.5.220 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (inside,outside) source static NETWORK_OBJ_192.168.2.0_24 NETWORK_OBJ_192.168.2.0_24 destination static NETWORK_OBJ_192.168.5.192_27 NETWORK_OBJ_192.168.5.192_27 no-proxy-arp route-lookup
!
object network obj_any
 nat (inside,outside) dynamic interface
object network SBS_2003
 nat (inside,outside) static interface service tcp smtp smtp
!
nat (inside,outside) after-auto source dynamic any interface
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 208.x.x.249 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.2.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 192.168.2.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0

dhcpd address 192.168.2.160-192.168.2.199 inside
dhcpd dns 192.168.2.49 24.29.99.36 interface inside
dhcpd wins 192.168.2.49 24.29.99.36 interface inside
dhcpd domain ascordio interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy Scordio internal
group-policy Scordio attributes
 wins-server value 192.168.2.49
 dns-server value 192.168.2.49
 vpn-tunnel-protocol ikev1
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value Scordio_splitTunnelAcl
 default-domain value ascordio.local
username bbalahadia password zWCAaitV3CB.GA87 encrypted privilege 0
username bbalahadia attributes
 vpn-group-policy Scordio
username jruggiero password O72LiZyIktgAjNrI encrypted privilege 0
username jruggiero attributes
 vpn-group-policy Scordio
tunnel-group Scordio type remote-access
tunnel-group Scordio general-attributes
 address-pool VPN_Users
 default-group-policy Scordio
tunnel-group Scordio ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:6fc678c44dcc88144c455b770a5a0967
: end
no asdm history enable


-  ISP INFORMATION (Time Warner Cable):
Usable IPS:  208.x.x.250-254  (Currently using .250, as our old SonicWall is setup with that)
Default Gateway:  208.x.x.249
Subnet Mask:  255.255.255.248
DNS:  24.x.x.35  and 24.x.x.35
0
 

Accepted Solution

by:
bns-nyc earned 0 total points
ID: 37821191
Was able to figure it out after playing with it for a while...thanks for suggestions all.
0
 

Author Closing Comment

by:bns-nyc
ID: 37841631
Was able to figure out after playing with multiple solutions / scenarios.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Overview The Cisco PIX 501, PIX 506e, ASA 5505 and ASA 5510 (most if not all of this information will be relevant to the PIX 515e but I do not have a working configuration handy to verify the validity) are primarily used within small to medium busi…
I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now