Apache Web Server - How to change URL default directory / webpage?

Hi
 
Just set up a LAMP stack. Default web page is index.html found in:
 
var/www/html
 
but I want to change it to:
 
var/www/html/web_application/index.php

Can anyone advise?

Thanks
Jason
LVL 11
Jason210Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AnuroopsunddCommented:
make the changes in /etc/apache2/httpd.conf to Document root to whatever directory you want to.
 if this file is not available then make the changes in  default-server.conf
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jason210Author Commented:
Since I'm using a machine image then the directory is slightly different:

/etc/httpd/conf/httpd.conf

In there i changed the DocumentRoot to var/www/html/moodle

Moodle is the web application folder. However, it does not seem to be working. Is there anything else that needs changing in this appache configuration file?
0
AnuroopsunddCommented:
Did you restarted the apache services?
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

AnuroopsunddCommented:
just edit /sites-available/default


Quote:
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride all
Order allow,deny
allow from all
# This directive allows us to have apache2's default start page
# in /apache2-default/, but still have / go to the right place
RedirectMatch ^/$ /apache2-default/
</Directory>  

and comment out #RedirectMatch ^/$ /apache2-default/

http://forums.vpslink.com/debian/496-apache2-default-how-change.html
0
ahoffmannCommented:
# you missed the leading / in
DocumentRoot to /var/www/html/moodle
0
Jayachandran PalanisamyTechnical Consultant - LinuxCommented:
Hi,
Could you please which version of Linux that you are using and how you installed Apache(Rpm/Tar/deb)?

Jay
0
Jason210Author Commented:
It's deployed as an image using Amazon Web Services. The image is working fine, but I have this splash screen that I want to avoid.

So I edit the httpd.conf file by changing these lines.

DocumentRoot  "/path/to/index/page"
<Directory "/path/to/index/page">

Obviously substituting that with real information.

The funny thing is it works until I reboot the server (which I do when I make an image) and the it just craters with error 500.

This is Unbuntu 10.04, and Apache2.

@ahoffman - I didn't miss the leading slash on the conf file.
0
Jason210Author Commented:
It seems that it's the application that is causing this error, the index.php file in the moodle folder.

As a test, I dropped an ordinary index.html file in there it worked.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.