Solved

Raid Partition Erros

Posted on 2012-03-31
21
688 Views
Last Modified: 2012-04-02
I purchased twp 3.0 TB drives to create a data drive in Windows XP Pro.  I used a Silicon Image card sil3114 and the software to create a raid set then the partitions.  I created 2 partitions in the raid set. Partition A was 1.9 gig Mirrored - Partition B was 760gb and striped to created a volume 1.4 gb.  The raid failed.  I'm trying to rebuild, but I cannot delete the partitions on both drives.  One of the drives is reporting a size of 753gb.  It will not show the 3.0 TB size.

I downloaded EASEUS Partition Master to see if that would fix the issue.  It did not.  I also tried DiskPart in Win7 and using the command to 'clean all' to wipe the drives.  No luck.  I know Windows XP has a 2 TB limit.  So my 1st partition has to be 1.9.

My Question
Is there a program that I can use to restore the full size of the drive so I can create the partitions again or delete the partitions cleanly.

Thank you in advance for a quick response.
0
Comment
Question by:Scott Huffman
  • 10
  • 6
  • 3
  • +1
21 Comments
 

Author Comment

by:Scott Huffman
Comment Utility
Update it looks like - but I'm not sure - that EASEUS is working to delete the bad partition information.  However, it's moving very slow - so to amend my question please add FAST too it. Thanks!
0
 
LVL 47

Expert Comment

by:dlethe
Comment Utility
The SI 3114 controller can't handle disks > 2.09TB.   MAYBE there is a firmware update. If not, least expensive option is to go to Win7 and let the O/S do the RAID and get rid of the controller.
0
 

Author Comment

by:Scott Huffman
Comment Utility
@ dlethe - Ok - thank's for the hardware tip - however, I need to delete the partitions.  That is my question.  Thank you if you can direct me to some software that will do the trick.
0
 
LVL 47

Expert Comment

by:dlethe
Comment Utility
the partitioning data is first 512 bytes of the disk.  So I typically boot the system to a USB stick with linux on it then enter
dd if=/dev/zero of=/dev/sda count=1 bs=512

(Assuming the disk is /dev/sda)

Plenty of nice freebie linux GUI partition managers that let you move things around, resize, set boot partition, etc.   Ubuntu.com has a utility that lets you burn a USB stick from windows right on the download page.   very painless.
0
 

Author Comment

by:Scott Huffman
Comment Utility
The drives were formatted NTFS. Thanks for the tip on ubuntu. Will it work fast?
0
 

Author Comment

by:Scott Huffman
Comment Utility
I also forgot to add that when I thought I deleted the partitions the 1st, the partitions came back when I initialized the disk.
0
 
LVL 15

Expert Comment

by:Perarduaadastra
Comment Utility
If you want to return the drives to factory condition and begin again why not just use the drive manufacturer's tools to write zeros to the drive sectors containing the partition information?
0
 
LVL 47

Expert Comment

by:dlethe
Comment Utility
to blow away the entire disk with linux

dd if=/dev/zero of=/dev/sda bs=1024k

(again, make sure /dev/sda is the disk you want)
if you have more then one disk, you can blow them both away at same time with:

dd if=/dev/zero of=/dev/sda bs=1024k &
dd if=/dev/zero of=/dev/sdb bs=1024k

(The & says to do the command in the background)

so the 2nd disk goes in foreground.  output will both go to the screen so press return a few times and when background job completes you will see results.
0
 

Author Comment

by:Scott Huffman
Comment Utility
These are Seagate 3tb drives.  Where can I obtain a utility to repair the drive?
0
 
LVL 15

Expert Comment

by:Perarduaadastra
Comment Utility
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:Scott Huffman
Comment Utility
0
 

Author Comment

by:Scott Huffman
Comment Utility
The SEATOOLS did not work - I selected the option to ZERO out the drive.  Yet I still have 746.52gb partition that I can't delete.

Suggestions?
0
 
LVL 15

Expert Comment

by:Perarduaadastra
Comment Utility
Something has just occurred to me...

Are you trying to deal with these partitions via the Silicon Image controller? If so, you may get better results if you connect the drives to the onboard SATA ports on the motherboard and then run the tools.
0
 
LVL 47

Expert Comment

by:dlethe
Comment Utility
I posted at the beginning .... CHECK THE FIRMWARE AND RELEASE NOTES FOR THE CONTROLLER.  YOURS PROBABLY DOES NOT SUPPORT DISKS > 2 TB.   MOST USB ENCLOSURES WON'T EITHER.  THIS IS AN ARCHITECTURAL CONSTRAINT OF THE BRIDGE CHIP USED IN THE CONTROLLERS.

The technical reason is that different commands must be used because the total number of blocks in this disk exceeds what you can represent as a 32-bit number.  This is most often only correctable by replacing the controller.   It is not an easy fix.
0
 
LVL 30

Expert Comment

by:pgm554
Comment Utility
You need a controller that handles UEFI and you need a 64 bit OS (Win7 64 SP1 or better) to set up GPT partitioning  in windows.

SP1 must be installed on the media before the install.

Using the Seatools overlay will help with older OS's,but if you want to do it right,get the right hardware and software before you begin.

One of the main issues is the new 4k sector disks and ANYTHING  over 2 TB is 4k these days.

And doing RAID is just asking for trouble with those disks.
0
 

Author Comment

by:Scott Huffman
Comment Utility
Hi ADMIN - I had no idea the program or the site I discussed was know for pirated software.  Thank you for removing the content.
0
 
LVL 47

Accepted Solution

by:
dlethe earned 500 total points
Comment Utility
I will try yet again ...
This controller was designed in 2006, well before any 3TB disks came out.  It can not physically address more then FFFFFFFE hex blocks (2.09TB).   THe partition table is on physical block 0.  If you delete physical block#0 then the partition table is gone.   This is a simple thing to do.  Seatools works. Your RAID doesn't work.   Any RAID controller doesn't care if a disk is going to be bootable when you build a LUN.  The controller doesn't care about GPT either.  It doesn't care about an O/S with a 2TB limit.

But what it DOES care about is the capacity.  The embedded SCSI instruction set that it presents to the HOST O/S [YES, SCSI, BECAUSE THAT IS THE COMMAND-SET THAT IT EMULATES TO THE HOST O/S] simply can not address blocks that exceed what can be represented in a 32-bit number.  While the back-end instruction set can address a block number > FFFFFFFEh, the front-end SCSI SEEK(10) and READ(10) among others don't let the host O/S get to the end of the disk.  Without support for the 12 and 16-byte SCSI CDBs, the host O/S can't get to all the data.  This explains the corruption.

MAYBE there is a firmware, BIOS, driver update that will support the larger disks, BUT the update has to come from the OEM manufacturer of the card.
0
 

Author Comment

by:Scott Huffman
Comment Utility
Hi - I've decide to give up on the 3tb goal.  I've switch the setup to 2tb based on your comments.  Now I'm just trying to use a power script to mirror the drives using power shell.  I've already started another thread on that topic.  Thanks for your follow up.
0
 
LVL 47

Expert Comment

by:dlethe
Comment Utility
Thx - I should have just posted the detailed explanation earlier.  The 753GB is a dead giveaway that the most significant address bit is getting dropped by the hardware.  Calculate 3 TB - ((2 ^32)-1)*512, and you end up with 753GB.  You end up with what I've always called ghost storage. Something that seems to be there, but isn't really, and it overlaps live data.

P.S.   Just because it *seems* to work if you don't build anything over (2^32) - 1 blocks doesn't mean it is working properly.  I don't have the programming manual for that chip (yes, I write RAID diags, configurators, even firmware professionally. I should have said that in first post to save you from wild goose chases that couldn't have possibly worked)

I would NOT use this card.  You already have to kludge the configuration, and you certainly have learned that a failure scenario can cost you data.   How do you know that this kludge won't have same results?  When a new drive is introduced, how do you know it won't try to rebuild the ghost 753GB all over again??   What if metadata is supposed to go in a reserved area at the end of the disk capacity? In your case it can't get there.   Just because it works now doesn't mean it will work in error scenarios. You just proved it doesn't work in one already.    [There is a way to programmatically set the HDD so that it reports and only uses 2.09TB, but while I have such code in the lab (because I wrote it), I don't believe there is any freebie consumer stuff that does it, and by no means am I offering or implying that I would give it away or even sell it.  I am just saying that there is a way to do this because some controllers do this in the firmware because they have to, and that we do this to test firmware often].

Formal advice is to contact manufacturer and see if this is a safe & tested config.  if not, then your data is at risk.
0
 

Author Comment

by:Scott Huffman
Comment Utility
Thanks again.  I won't waste my time again.  I'll use a proper card that I now supports the devices. :-)
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

The article will include the best Data Recovery Tools along with their Features, Capabilities, and their Download Links. Hope you’ll enjoy it and will choose the one as required by you.
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup". After a while, you have entered a loop for Auto repair which does not fix anything and you will be in a  panic as all your work w…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now