Problems with Shared Folders SBS2011

We have just installed a new SBS server for a company who are moving away from another domain controller.

SBS2011 is installed but all the users were created via the Active Directory Console not the SBS wizard.

We've removed all the PC's from the old domain and joined them to the new SBS2011 domain.

All users on the SBS2011 can login no  problems.

However, they cannot access ANY shares...not the public not any we have created evren though we added 'everyone' all users etc ....

Can anyone help with this? we even tried to create a user using SBS2011 console and still they cannot see all the shares / files inside....
deepslalliAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

motnahp00Commented:
Both Shares and NTFS permissions are correct?
0
Alan HardistyCo-OwnerCommented:
Did you setup the shares adding share permissions AND security permissions?

If so - what permissions were set on the share and the security settings?
0
deepslalliAuthor Commented:
We setup the share permission and the security permissions.

We have also found that after setting these if we point to the servers IP (192.168.*.*\[sharename}) to access the share it allows us access and works. However if we access the unc path \\server01\[sharename] or \\domain.local\[sharename] it will allow us to see the shares but either not access them or show us an empty folder.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Alan HardistyCo-OwnerCommented:
Do you have any entries in your hosts fileor lmhosts file on the client computers (c:\windows\system32\drivers\etc)?

The entries would show your SBS servername and the wrong IP address?

Are you clients pointing to the SBS server for their DNS settings?

Is the server NIC settings configured to point only to the SBS server IP address for DNS and nothing else?
0
deepslalliAuthor Commented:
Could this be an issue with DNS? if we do an nslookup on itself (svr01) as it is the dns the server, it will not find itself but if we use the full name srv1.domain.local it finds itself without issue. I have also confirmed it can see the workstations without having to add the domain extention.
0
motnahp00Commented:
Please show me your output when you run "net share" on your server.
0
deepslalliAuthor Commented:
The Host file is empty, there is no settings for the servers address.

All clients are pointing at the SBS server for DNS and google's DNS.

The NIC settings on the server has the SBS servers IP and 8.8.8.8.
0
deepslalliAuthor Commented:
File attached with the results of the net share command run on the server.
netshare-results.txt
0
Alan HardistyCo-OwnerCommented:
Remove Google's DNS servers from everything server and client.

Add your ISP's DNS server IP addresses to the DNS server properties> Forwarders tab and Googles if you feel so inclined.

SBS must only ever point to itself and nothing else and it only sets itself up this way, so whoever changed it caused your problems.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
motnahp00Commented:
Is the UserShare even resolving automatically through UNC on a client machine?
0
Alan HardistyCo-OwnerCommented:
Once you have removed Googles DNS settings from the server and clients (and DHCP if you set it up there too), you may have to reboot the server and all clients to make things work.

It is nothing to do with Share permissions and everything to do with DNS.
0
motnahp00Commented:
Instead of configuring Google's DNS server on each machine, create a stub zone on your DNS server.

dnsmgmt.msc -> Right click Forward Lookup Zone -> Click New Zone -> Select Stub Zone -> 2nd Radio button is okay -> google.com -> Entire a few of the IP addresses for Google's DNS servers.

You can find out their DNS IP addresses with nslookup.

nslookup
set type=ns
google.com
0
Alan HardistyCo-OwnerCommented:
Why would you even consider doing that?  What purpose does it serve?

Do you know SBS at all?
0
deepslalliAuthor Commented:
It was an inherited installation and SBS is not something I have had a lot of dealings with.

Do we have to reboot? I have made the changes and deleted the dhcp leases for the clients. I am now able to access the server and shares using the unc name.

I only ask because we have some software on there that is running in production and could cause some issues to bring it down.
0
Alan HardistyCo-OwnerCommented:
You shouldn't have to reboot - only if accessing the shares still doesn't work after removing the Google DNS IP's from everything.

If all is good now, you should be fine.

SBS is something that shouldn't be messed with and most settings are configured by the Wizards in the SBS Console.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.