Server Administartion Server Instances

I’m new to My SQL. Im trying to trying to change the Data directory location to that of the server Instead of the default C:Program Data/MySQL/MySQL Server 5.5/data. I changed the my.ini file so that the database directory was pointing to the server and then stopped the database server and tried to restart the database. It would not re-start.. I copied the old my.ini file back and the database restarted. I thought, well maybe it can not find the same dabases in the new directory that I had in old directory , so I copied the entired database structure and tried the new my.ini database file again  and it still would not restart after I stopped it. ANy suggestions?

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hello miker54,

First I would say, you posted MySQL related question in SQL Server zone...

have a look at the link below for your question...
Could you detail what you mean by pointing it to the server?
Make sure that the settings where they are originally matches the new location.
There should be an error log that will include the reason why it could not start.
You hav to copy all the directories in the data folder to h new location and not just some.
You could reconfigure and alter the data location.
miker454Author Commented:
Hi Barlet,

I appreciate the link and the suggestion of switching categories. I followed the procedure of this and other links. The problem is I did modify the file, so that the data directory is  datadir="Y:\dev224\MySQL\data" .I copied the original data directory using the windows explorer. I do see a directory when I sign up to the original configuration that i don't see in the actual directory  information_schema . But I copied the directory and stopped the Server and tried to restart, but it would not restart.

Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

What is the error in the log file?  Do the permissions on the new location match the ones at the original?
cacls c:\program files\mysql...\data

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
miker454Author Commented:
Firt of all thanks to arnold and  barlet for trying to help. I decided to try to isolate the problem by simply changing the database root from the default "C:\ProgramData\MySQL\MySQL Server 5.5\data\" to "C:\ProgramData\MySQL\data\" . So I copied the data directory to the C:\ProgramData\MySQL\ and then tried to stop and start the My SQL database community version. I was able to start and stop and it runs fine. Tried switching the data directory to another phisical hard drive in the computer e:\My SQL\data. Stopped and started and it ran fine. Tried to put the data on a Server drive mapped on the client computer z:\MySQL\data and it would not start. I tried giving the directories all the permissions, but I could not get it to run. This is the My SQL community version 5.2.22 .  Is there something i need to do to the file server to allow me to access the database files at the client machine. I run paradox tables of the file server without any problems.

2012-04-02 02:42:21 - Workbench will use cmd shell commands to start/stop this instance
2012-04-02 02:42:21 - Status check of service 'MySQL55' returned stopped
2012-04-02 02:42:21 - Status check of service 'MySQL55' returned stopped
2012-04-02 02:42:27 - Status check of service 'MySQL55' returned stopped
2012-04-02 02:42:27 - Starting server...
2012-04-02 02:42:29 - Status check of service 'MySQL55' returned stopped
2012-04-02 02:42:29 - Server start done.
2012-04-02 02:42:29 - Status check of service 'MySQL55' returned start pending
2012-04-02 02:42:44 - Status check of service 'MySQL55' returned stopped
2012-04-02 02:42:44 - Starting server...
2012-04-02 02:42:46 - Status check of service 'MySQL55' returned stopped
2012-04-02 02:42:46 - Server start done.
2012-04-02 02:42:46 - Status check of service 'MySQL55' returned start pending

Im running MySQL 5.5.22 on windows 7 . The server runs server 2008.

Instead of using mapped drives, see whether you can configure space on the server that can be accessed by the system using iscsi

Any reason why you are not running the MySQL server on the server?
miker454Author Commented:
Thanks to both of you for helping. I'm going to close this question and consider it answered. I stupidly tried to run the My SQL on the client machines and use the file server to store the data. Obviously, this won't work (lowers head in shame!!). In my defence I spend hours trying to get My SQL to work on the server computer and I could not even see it on the client computers. Thanks for the help. I posted the question I should have asked on the My SQL section. By the way this is it:

Installed MySQL Server 5.2.22 on a Windows 2008 server. Using the MySQL workbench 5.2 cummunityt edition, the database is working on the server and I can actually log into it via ODBC on the server computer. I have tried to log on the MySQL server on windows 7 client machine using ODBC and it will not see the My SQL server. I have disabled the windows firewall on both the server and the client and I still can not see the My SQL server on the client machine. Openned port 3306 and nothing.
Any suggestions?

You need to first to configure MySQL to listen for tcp/ip connections.
You the have to use the advanced firewall settings and open the port you configured in the prior to allow access from the private/domain network.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.