Solved

Cannot RDP into server through remote site Win SBS 2011

Posted on 2012-04-01
4
925 Views
Last Modified: 2012-04-05
Today, I cannot connect remotely to my server using the Remote Web Access site. The RWA site is up and running, and I can remote in to all of the workstations on the network, but for the server, I get the error:

Remote Desktop can't find the computer "****". This might mean that "****" does not belong to the specified network. Verify the computer name and domain that you are trying to connect to.

I have checked domain name, etc, everythings the same as the rest of the network. I have been able to in the past, but not recently. could an update have screwed up this feature? Remote access is extremely important, so any help would be appreciated! Thanks
0
Comment
Question by:Lee_Hamster
  • 2
4 Comments
 
LVL 9

Expert Comment

by:borki
ID: 37794923
You say that all other PCs are still working, therefore the remote gateway service is still working.

I suggest to try to connect to server using RDP from a PC that is local on the network. If this works ok, I would try logging in using a RDP client from a remote PC. You would need to specify the remote gateway server. in the advanced section.

You may find additional logging information in the Windows logs under Remote Desktop services

Also make sure you have patched the server with the March security updates as they have a released an update to fix a vulnerably in the RDP protocol. Reboot after installing the updates.
0
 

Author Comment

by:Lee_Hamster
ID: 37799124
I tried using a local computer's RDP, but got the same error as before. I'll check the logs as well. Thanks
0
 
LVL 34

Accepted Solution

by:
Shreedhar Ette earned 500 total points
ID: 37800105
- Check the Below Regsitry:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber

Make sure that PortNumber is 3389. If it is not then modify PortNumber to 3389 and reboot server for change to take effect and Tey RDP.

- Check for any Windows Updates installed on the Server. If any, Uninstall them and try local computer RDP.
0
 

Author Closing Comment

by:Lee_Hamster
ID: 37813108
Worked perfectly, the port number was incorrect. Thanks a lot.
0

Featured Post

Networking for the Cloud Era

Join Microsoft and Riverbed for a discussion and demonstration of enhancements to SteelConnect:
-One-click orchestration and cloud connectivity in Azure environments
-Tight integration of SD-WAN and WAN optimization capabilities
-Scalability and resiliency equal to a data center

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The articles for turning off the Client firewall policy on the internet are for SBS 2008 and don't really help for SBS 2011. They actually moved the Client firewall policy. In 2011, the client firewall policy has moved to the SBS computers conta…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question