Solved

Windows cannot access the specified device, path, or file.

Posted on 2012-04-01
23
1,890 Views
Last Modified: 2012-08-13
I am currently running a Terminal server that is giving me quite a headache lately when attempting to run programs off of a network file server.

This is a system running Server 2003 Standard with Service Pack 2.
Network File server is Server 2008 Standard Fully patched.

Several times a day, users will encounter issues trying to run programs off the network drives.
They double click the icon and get "Windows cannot access the specified device, path, or file.  You may not have the appropriate permissions to access the item."

I tried manually running the program by opening up the CMD prompt, going to the drive, and running the program, and it loads just fine.    

I have already checked the system for Malware, have confirmed that it is receiving Group policy updates, and that DNS is set to the correct servers, and that Time Sync is established between the file server and this terminal server.    


This error will happen until I reboot the server, then it will work for a while until the process happens again.
0
Comment
Question by:1CA-Robert
  • 15
  • 4
  • 2
  • +1
23 Comments
 

Author Comment

by:1CA-Robert
ID: 37794221
Here is a screenshot of the error.      Just happened again, causing me to have to reboot the terminal server.
snap001.bmp
0
 
LVL 11

Expert Comment

by:Venugopal N
ID: 37794644
Check if the files has been blocked on the Server.

Right-click on the file and choose Properties. You’ll see a button called Unblock at the bottom.

Also check if you have any event failure log and it may help to figure out the issue.
0
 
LVL 5

Expert Comment

by:ssujai
ID: 37794656
As the error sepecifies, you need to check the access permissions the user have in the network share. can u post the permission details here?
0
 

Author Comment

by:1CA-Robert
ID: 37797658
The user can open the programs after a fresh reboot.    After a while, if they are out of the programs, it will then start back up.      I thought of permissions at first, too, but then they should get this issue all of the time.

I had one DCOM error showing in the error log:

DCOM ERROR

I have no explicit deny rights and had set the everyone group to access to the icon to run the program:

icon rights
The Network folder gives them rights under the "Domain Users" group (there are no other explicit deny rules in other groups:

Network Folder Rights:

Here is the file properties of what the icon runs in the network folder:

Program Icon Properties


When I double click it, I get the error:

Icon Error


However, if I open up a CMD prompt (as the user, not running as administrator)   it opens up without a problem.
0
 

Author Comment

by:1CA-Robert
ID: 37799239
UPDATE:    I may have narrowed it to the drive mapping itself dropping out.       I was able to run the programs from

Start-->Run  and using the UNC path to the program:   \\Server\Share

I ran NET USE and noticed that the mapped drives were showing "Unavailable" even though I could view the files in them.    

The Drives are mapped using Group Policy.  

I found this article: http://techibee.com/group-policies/all-about-drive-mapping-in-group-policy-preferences/202

I followed the instructions in this and rebooted the Terminal Server.    when it rebooted, the NET USE shows drives all in "OK" status.  

NET USE RESULT AFTER REBOOT
Crossing my fingers and hoping this resolves it.
0
 

Author Comment

by:1CA-Robert
ID: 37802717
Unfortunately, it did not help, but the problem looks to be related with the drive mappings.     Here is a NET USE screenshot when the program was not running from the icon:

NET USE - Icon not working
At least now the problem is narrowed down, but it is still a problem.
0
 

Author Comment

by:1CA-Robert
ID: 37805627
Tried net config server /autodisconnect:-1 command, but problem is still occurring.
0
 

Author Comment

by:1CA-Robert
ID: 37812046
no luck.    The drives still disconnect.    

I completely removed and recreated the shares on that file server, too.   Unfortunately, I still have them dropping.     Any suggestions?
0
 
LVL 21

Expert Comment

by:Larry Struckmeyer MVP
ID: 37876688
Start with some basic troubleshooting:

Patch cords at both ends.
Change Switch ports.
Verify that the properties of the nics and/or the power settings are not causing them to go to sleep or to time out.
Check that your anti virus and/or firewall settings do not mess with your connections.
Verify there is no EMI kicking in...Microwaves, ballasts, alien space craft.

I have even seen intermittent power issues cause the switch to blink, breaking the connection.
0
 

Author Comment

by:1CA-Robert
ID: 37876950
Put in brand new Cat 6 patch cords, we have swapped out switch ports.  

I have the power option set to Always on.

Power options
The Terminal server is on a 2200VA managed UPS that doesn't show power being lost.

The only option I see for the NIC itself is PME, and that is disabled.

NIC PME

I looked at the local news feeds and nothing showing any Alien crafts dropping by.   Too bad, I wish they would beam this issue away.  

 The server room is isolated away from any microwave ovens.
0
 
LVL 21

Expert Comment

by:Larry Struckmeyer MVP
ID: 37877572
This is almost postively a physical layer issue.    Windows doesn't do this.  

As a next step I would replace the switch, even if I went to the local store and got a small one for a test then took it back.  (not something I like to do)  Verify the switch if plugged into the battery side of the UPS.

Verify you have the latest nic drivers, and if so, try stepping back one generation.  On the screen shot of the nic properties... all those offload settings.. try disabling those.  Do them one at a time.

Investigate smb signing and turning it off/on, which ever is the reverse of the current setting.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:1CA-Robert
ID: 37878009
I would suspect the switch, however, other workstations running Win7 on the switch seems to be running fine.   The problem appears to be with the Terminal server 2003 unit.      The entire server room is on UPS (verified with plugged into battery/UPS sides).       I'll go through the NIC settings and disable the rest of the offload settings to see if that may help.
0
 

Author Comment

by:1CA-Robert
ID: 37895309
Disabled the offload settings, and tried all of the versions of drivers released for that NIC.    Still no luck.
0
 

Author Comment

by:1CA-Robert
ID: 37908536
No other experts that can help out?         This is still a problem.
0
 
LVL 5

Expert Comment

by:ssujai
ID: 37909173
You may need to check the permission settings once more. I understand that the exe that the users are trying to run resides in a share drive. You are mapping the exe to the user's desktop?

You may have to think along the following lines:

What level of access do the users have at the W: share drive. Try giving full access on share level

Do the users have access to browse through the W drive and reach the CSA folder?

Does the exe itself try to access any other files that user doesnt have access to?
0
 

Author Comment

by:1CA-Robert
ID: 37914881
Users can run if done through the UNC.     \\Server\Accounting\CSA\CSA,exe  runs without issue.

w:\ = \\Server\Accounting\

W:\CSA\csa.exe --> won't run.

The share is wide open on the permissions (Domain Users: Full Control & Everyone: Full Control)  as shown earlier in this posting.
The Security on the directory is set form Domain Users: Full Control as well.

Share permissions
0
 
LVL 5

Expert Comment

by:ssujai
ID: 37914916
When the user logs in ,whose permission does it use to map W?Can you cross check on that?Disconnect the drive,manually map it using the user account and try

Also in the screenshot above, I can see only Everyone in the share permission. You may want to change it to domain users and try
0
 

Author Comment

by:1CA-Robert
ID: 37915020
Changed.      I will reboot and see if it does it again.    It usually happens after an hour or two.

Updated permissions
0
 

Author Comment

by:1CA-Robert
ID: 37917602
Unfortunately, that didn't help.    It still does the same thing.
0
 
LVL 5

Expert Comment

by:ssujai
ID: 37917787
Can you check on my earlier query?

When the user logs in ,whose permission does it use to map W? I am trying to understand how the terminal server session access the drive. That would be the root level..We can go from there to the .exe permissions
0
 

Accepted Solution

by:
1CA-Robert earned 0 total points
ID: 38094094
Closing question.     Problem was not fixed.
0
 

Author Closing Comment

by:1CA-Robert
ID: 38112537
Aged question that was not able to be solved.
0

Featured Post

Free camera licenses with purchase of My Cloud NAS

Milestone Arcus software is compatible with thousands of industry-leading cameras for added flexibility. Upon installation on your My Cloud NAS, you will receive two (2) camera licenses already enabled in the software. And for a limited time, get additional camera licenses FREE.

Join & Write a Comment

Even if you have implemented a Mobile Device Management solution company wide, it is a good idea to make sure you are taking into account all of the major risks to your electronic protected health information (ePHI).
If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now