Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win



Posted on 2012-04-01
Medium Priority
Last Modified: 2012-06-21
I'm having a "UNMOUNTABLE_BOOT_VOLUME" BLUE SCREEN error on my VM, no recovery working while using install cd.
The VM has 3 disks of 256 Go, the second one has ntfs errors, I cannot run a chkdsk on it, the first disk (OS) seems to be OK (while using gparted) but cannot boot

Any help will be appreciated
Question by:jamesniox
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
LVL 124
ID: 37794108
have you tried connecting the virtual disks to another Windows helper VM to check files, folders and data.

but before running chkdsk, make sure you have full backups not vmware snapshots.

Author Comment

ID: 37794125
HI, yes I tried :
- the second disk cannot be accessed, browser or any thing else
, no I have no full backup, some error is fired when I try to make a copy, even in SSH (cp : read error ... )

Author Comment

ID: 37794131
I this can help too, I have this error with the GPARTED tool for the corrupted vmdk :
cluster accounting failed
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

LVL 124
ID: 37794138
okay, it looks like your underlying datastore is having issues.check RAID controller for RAID failure, or local host disks for failure.

your vmdks are corrupted because of hardware storage failure.

Author Comment

ID: 37794143
That's what I was thinking, actually they are local SATA disks, and I have no clue of how to check that on esxi.

Author Comment

ID: 37794186
I fired a "dosfsck" command, I'm waiting to see the results
LVL 124
ID: 37794189
check the VMware logs, but if they are SATA individual disks, a disk is failing with errors.

login to ESXi console or SSH, /var/log for logs
LVL 42

Expert Comment

by:Paul Solovyovsky
ID: 37794207
Also make sure you have the right disk booting, sometimes they get out of order, make sure bootable is scsi(0:0)

Author Comment

ID: 37794209
I have this type of error message  :

Apr  2 00:10:26 vmkernel: 0:11:10:23.965 cpu1:4617)NMP: nmp_CompleteCommandForPath: Command 0x28 (0x41027f358d40) to NMP device "t10.ATA_____SAMSUNG_HD103UJ________
Apr  2 00:10:26 vmkernel: 0:11:10:23.965 cpu1:4617)ScsiDeviceIO: 1688: Command 0x28 to device "t10.ATA_____SAMSUNG_HD103UJ_________________________S13PJ1BZ202358___
Apr  2 00:11:04 vmkernel: 0:11:11:02.064 cpu1:4617)<3>ata3.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
Apr  2 00:11:04 vmkernel: 0:11:11:02.064 cpu1:4617)<3>ata3.01: (BMDMA stat 0x40)
Apr  2 00:11:04 vmkernel: 0:11:11:02.064 cpu1:4617)<3>ata3.01: tag 0 cmd 0x25 Emask 0x9 stat 0x51 err 0x40 (media error)
Apr  2 00:11:04 vmkernel: 0:11:11:02.070 cpu1:4617)<6>ata3: EH complete
LVL 124
ID: 37795335
hard drive needs replacing.

the virtual disk are probably corrupted because they cannot be read.

Author Comment

ID: 37795590
Too bad !!!

Thanks, is there a way to force copy ignoring read errors so as to recover a part of the data from the vmdk files?

I'm about to try "Ddrescue" embeded in a rescue disk : http://www.gnu.org/software/ddrescue/manual/ddrescue_manual.html#Invoking-Ddrescue to copy data in a mounted vmdk stored in a separate disk (datastore) to the VM I need to recover
LVL 124

Accepted Solution

Andrew Hancock (VMware vExpert / EE MVE^2) earned 640 total points
ID: 37795643
I would run a disk checker from the manufacturer to recertify the drive.

or use an imaging tool with ignore bad sectors flag.
LVL 124
ID: 37795645
If the data is really important and you have a BUDGET for DR. STOP

send to Kroll Ontrack.

Author Comment

ID: 37803245
I finally succeeded to rescue main data, with :

1 - using an imaging tool with ignore bad sectors flag, but on the virtual images : "Ddrescue" embeded in a rescue disk

2 - mounting the virtual disk as slave on another virtual server.

thanks for all your helps.

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Issue: One Windows 2008 R2 64bit server on the network unable to connect to a buffalo Device (Linkstation) with firmware version 1.56. There are a total of four servers on the network this being one of them. Troubleshooting Steps: Connect via h…
It’s time for spooky stories and consuming way too much sugar, including the many treats we’ve whipped for you in the world of tech. Check it out!
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This video shows you how easy it is to boot from ISO images for virtual machines with the ISO images stored on a local datastore on the ESXi host.

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question