Email

Hi to all,
Iam facing a problem on my email account settings..The secenario is:
We have requested a software for our Procurement Department to an India Company...We provide them all specs and roles, and one of them was that it should send emails automatically to users, when a new user is created on admin console!
During test period we were using their smtp details and it worked perfect...The problem started when we decied to move the application to our server: They asked us to configure our own SMTP details (smtp server: smtp.ibpmail.com/port 465)!
Since then, when a new user is created it returns an error message saying the email sending failed...We contacted our supplier and they said, it might be problem a problem with our smtp port on firewall! Our firewall is configured to accept outgoing traffic (nothing is blocked)!
Last week we contacted our ISP to make sure this port is not blocked (465), and they ensured it is not...

PS: we do not have an exchange server..! Our email provider is based on Geneva...

Any Help on what might be wrong!
Ercélio Pedro MabotaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ercélio Pedro MabotaAuthor Commented:
Even with the error, the users are being created on application...but they need to be notified!
0
AnutechnologiesCommented:
It may be that the server is not configured to relay messages from your application/server.  Ask your ISP to allow relaying from that address.  Most ISPs will open up their internal web addresses to allow relaying for their customers, but others you need to ask.  The port may be open but the server thinks you are spam without authentication.  Allowing relay will allow you to send from the application without authentication.
0
sachinpatil10dCommented:
Try with
SMTP Port number 587

check if it works
0
Introduction to Web Design

Develop a strong foundation and understanding of web design by learning HTML, CSS, and additional tools to help you develop your own website.

AnuroopsunddCommented:
1. first to confirm if the traffic is not blocked from your network. you can do telnet to email server by the port. if it is successful it should be fine.
telnet smtp.ibpmail.com 465

2. you have to get it confirmed with the Email provider to check the relay for this new server. Email server should allow relaying mails.
0
Ercélio Pedro MabotaAuthor Commented:
C:\Documents and Settings\ercelio.mabote>telnet smtp.ibpmail.com 465
Connecting To smtp.ibpmail.com...Could not open connection to the host, on port
465: Connect failed
0
AnuroopsunddCommented:
can you try from your gateway/router. may be telnet is blocked from your network to outside.
0
Ercélio Pedro MabotaAuthor Commented:
iam using a linux based gateway...iam new to linux and i dont know how to run telnet on it! I access the gateway through a https using  Clear OS
0
AnutechnologiesCommented:
I tried 587, 25 and 465.  None of them gave results from the outside.  It may only respond to certain IP addresses, which goes back to requesting relay access for your ip/app.
0
Ercélio Pedro MabotaAuthor Commented:
if i change the port from 465 to another, i think i will not be able to receive emails at my inbox...as this smtp port is provided by our email provider!
0
Ercélio Pedro MabotaAuthor Commented:
the account configured to notify users is helpdes@akdn.org and i tried changing its smtp details and i stopped sendinding and receiving emails!
Iam now trying to solve it with my ISP...once done i will let u know!
0
AnuroopsunddCommented:
Keep posted.
0
Ercélio Pedro MabotaAuthor Commented:
this is the error i get from the applictaion when i change the port number:
A socket operation was attempted to an unreachable network 194.151.203.112:135
0
Ercélio Pedro MabotaAuthor Commented:
I went to our gateway/firewall and changed the smtp definitions there! I replaced the old ones with the one provided by our ISP (extsmtp.tdm.co.mz) which require no authentication using port 25, and then i sent a test email from there and it was forwarded!

When i use the smtp definitions from my Email Provider, the application returns an error saying: "an existing connection was forcibly closed by the remote host"...see the attach!

Now when i log to the application and set the same definitions, the user is created successfully with no error reported, but it still does not notify the user about his creation...

Is this related to my mail provider or ISP?
error.jpg
0
AnuroopsunddCommented:
This is related to your email provider server as the email server did not responded or closed the request.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ercélio Pedro MabotaAuthor Commented:
Thanks...i will be in touch with them and update u as soon as possible!
0
Ercélio Pedro MabotaAuthor Commented:
This is the reply from our email provider:


Your IP is already allowed to use ibpmail smtp gateway since a long time.

Please verify on your side what could be blocking.

Ibpmail admin confirmed me that you should be able to telnet the port 465 of smtp.ibpmail.com
See their reply:

Like we spoke on the phone we don’t see any problems from the IP address 196.28.236.186.
We see hundreds of messages being relayed from AKDN users on our secured SSL server front03 from the IP address 196.28.236.186.

As a matter a fact we even have excluded this IP address from SPOOFING
0
Ercélio Pedro MabotaAuthor Commented:
HI...I logged on the server hosting the application, opened my browser there and went to www.canyouseeme.org and introduced the port number there!

See the result on the attached file...

Any clue?
465.jpg
0
Ercélio Pedro MabotaAuthor Commented:
Is there any chance that our router could be blocking it?
Network.jpg
0
Ercélio Pedro MabotaAuthor Commented:
An existing connection was forcibly closed by the remote host

This is the common erro i get when usinng our Email provider settings
0
Ercélio Pedro MabotaAuthor Commented:
I went to Event viewer on server and found this:

Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 4/5/2012 5:01:41 PM
Event time (UTC): 4/5/2012 3:01:41 PM
Event ID: d2b5752fe32d490d950b2b9f6afef7be
Event sequence: 28
Event occurrence: 1
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/1/Root/agakhan-3-129781115840312500
    Trust level: Full
    Application Virtual Path: /agakhan
    Application Path: G:\xtenza\build27mar\Build\
    Machine name: AKFMZSERVER
 
Process information:
    Process ID: 460
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE
 
Exception information:
    Exception type: SmtpException
    Exception message: Failure sending mail.
 
Request information:
    Request URL: http://localhost/agakhan/prjuser_profile_Child1.aspx?Sel_Org=203&MenuId=4&proid=7&PreActId=731790 
    Request path: /agakhan/prjuser_profile_Child1.aspx
    User host address: 127.0.0.1
    User:  
    Is authenticated: False
    Authentication Type:  
    Thread account name: NT AUTHORITY\NETWORK SERVICE
 
Thread information:
    Thread ID: 6
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace:    at NPI.prjuser_profile_Child11.addusers()
   at NPI.prjuser_profile_Child11.Btnsave_Click(Object sender, EventArgs e)
   at System.Web.UI.WebControls.Button.OnClick(EventArgs e)
   at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument)
   at System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)
   at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
   at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
 
 
Custom event details:

For more information, see Help and Support Center at
0
Ercélio Pedro MabotaAuthor Commented:
Problem solved...We tested using our ISP smt definitions and it worked fine!
Thank to all of u for all support
0
Ercélio Pedro MabotaAuthor Commented:
it helped in a clue
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Internet Protocols

From novice to tech pro — start learning today.