Chrome in Vista: java plugin could not be found even though it is installed

hello all,

i have a chrome browser with version 18.0.1025.142 m.

on my computer i have installed jdk and jre with version 1.6.0_31

C:\>java -version
java version "1.6.0_31"
Java(TM) SE Runtime Environment (build 1.6.0_31-b05)
Java HotSpot(TM) Client VM (build 20.6-b01, mixed mode, sharing)

but when i open the url https://java.com/en/download/testjava.jsp
i got the message:

"java plug-in is old and was blocked.
"Java (TM)" is needed to display element on the site."

this problem is still there, after i installed java from
http://java.com/de/download/chrome.jsp

i don't have this problem in firefox and IE. They both detect the java.

any suggestion?
thanks,
wantime
https.jpg
wantimeAsked:
Who is Participating?
 
wantimeConnect With a Mentor Author Commented:
a wrong dll was used.
0
 
wantimeAuthor Commented:
when i input chrome://plugins/ in the url, i get the information about java plugin:

Java - Version: 10.2.1.255
NPRuntime Script Plug-in Library for Java(TM) Deploy

i wonder why the version nr. is not 1.6.0_31
0
 
wantimeAuthor Commented:
under url chrome://plugins/  i clicked details, then i got following information, it seems that  jdk toolkit has a higher version...



Java - Version: 10.2.1.255 Kritisches Sicherheits-Update herunterladen
NPRuntime Script Plug-in Library for Java(TM) Deploy
Name:      Java Deployment Toolkit 7.0.20.255
Beschreibung:      NPRuntime Script Plug-in Library for Java(TM) Deploy
Version:      10.2.1.255
Speicherort:      C:\Windows\system32\npDeployJava1.dll
Typ:      NPAPI
        Deaktivieren
MIME-Typen:      
MIME-Typ      Beschreibung      Dateiendungen
application/java-deployment-toolkit
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.