Need help regarding plugins and setup in Eclipse for HTML 5

I've recently installed Eclipse 3.7.2 - i'm trying to set it up so that I can do some android development, flex and html 5.
I think i have it working for the first 2 but now trying to find some plug ins for HTML 5 - i see references the Javascript Web developers version. Now surely I don't need to download another eclipse?
can anyone advise how I can get the required packages for html 5 support in my current J2EE version of eclipse?

thanks.
LVL 39
blue-genieAsked:
Who is Participating?
 
Shaun McNicholasConnect With a Mentor Senior Marketing TechnologistCommented:
html 5 is simply a standard html code base which eclipse should support most of the tags.
Here is a question posted and answered in another forum that suggests that when you setup the initial page tag it should be tagged as simply <!DOCTYPE html> not the standard tag with the extra public reference... just leave out the specific reference to any of the W3C standards.  <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
http://superuser.com/questions/142997/enable-html5-tags-on-eclipse

Once the parent tag is pointing to the pure html format standard eclipse should recognize all the html 5 tags as long as you have the most recent version of eclipse installed.

Also for support using the javascript references for html5 you'll want to install some additional libraries in Eclipse
http://marketplace.eclipse.org/category/free-tagging/html5
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.