£ being prefixed with  in email messages sent using CDO

Hello,

I recently did a Windows 2003 Server update and since then, plain text emails sent from my website using CDOSYS prefix £ signs with Â, e.g. £

Furthermore, prior to the Windows update, plain text emails from my website were sent using a fixed pitch font (Courier or Courier New maybe). However, they are now sent using a variable font causing email content to be misaligned.

So, in summary...

1. I want to remove the £ and only display £
2. I want to send the email using a fixed pitch font.

Here is the ASP code I currently use to send the email...

Set myMail=CreateObject("CDO.Message")
myMail.From="xyz.abc.com"
myMail.To=varEmail
myMail.Subject="blah de blah"
myMail.TextBody=msgBody
myMail.Send
set myMail=nothing

Please note, I have tried adding the following line but it made no difference (i.e. £ remained in the emails)...

myMail.bodypart.charset = "utf-8"

I hope someone can help!

Regards,

Mark.
funassetAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kim WalkerWeb Programmer/TechnicianCommented:
There are no fonts in plain text emails, only characters. The font used to display plain text emails is set in the preferences of the email reader application.

It would help to see the contents of msgBody.
Dale BurrellDirectorCommented:
The problem with the pound sign if that you are using the wrong codepage. The data is stored in unicode, but you're codepage is set to windows-1252 or similar. Probably you've been using the server defaults and they've changed with the upgrade. http://www.w3schools.com/asp/prop_codepage.asp. This may well be causing your other problem e.g. additional spaces or similar because as xmediaman points out with plain text no font information is sent.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
funassetAuthor Commented:
I set the codepage to 65001 and all is now well.

Thank you for your swift response.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP

From novice to tech pro — start learning today.