• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 776
  • Last Modified:

Excel Desktop Icon does not launch the File

I have a user that has created old .xls documents that she has on her desktop and she also has new .xlsx documents that she has on her desktop.

I intsalled Office 2010 and once I installed it, I tried to open up all my excel documents. The excel documents that are on the desktop (.xls ) open just fine when selected. However when I selected the excel documents .xlsx they do not open they sit there and nothing happens. If I were to luanch Excel 2010 my my programs and then open the excel program and try to open the same desktop document in .xlsx, it will open that document just fine.

Would anyone has suggestions on what is going in?

Thanks
0
cmdolcet
Asked:
cmdolcet
  • 3
  • 2
  • 2
1 Solution
 
ramromconsultant Commented:
Since you use windows 7 there may be some differences.

Right-click on a desktop icon - see what shows up in the context menu.
If there is an Open With - select that then Choose Program.
If excel is in the list choose that and check Always use.

Also (windows 7) click start then Default Programs - see what (if anything) is specified for .xlsx. If it is not excel, change that. You may need administrative permission.
0
 
ramromconsultant Commented:
Note your command prompt and drive letters may be different

Also from a command prompt:
C:\>assoc .xlsx
.xlsx=Excel.Sheet.12

C:\>ftype excel.sheet.12
excel.sheet.12="H:\Program Files\Microsoft Office\Office12\EXCEL.EXE" /e

If assoc gives you File association not found for extension .xslx then you will  need to add one.

c:\>>ftype | find "Excel" will show you all the ftypes that refer to Excel. If  you see
Excel.Sheet.12="H:\Program Files\Microsoft Office\Office12\EXCEL.EXE" /e
then
assoc .xlsx=Excel.Sheet.12
0
 
cmdolcetAuthor Commented:
ModSquad, No the previous question was how to set the default program to recognize the .xlsx file type to Excel. I have set that and things work in that area, however everytime I want to open a desktop shortcut with the extension .xlsx the program will think then never open. However I can open it from the Excel File open option.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
ramromconsultant Commented:
You said nothing about shortcuts in your question. Shortcuts have .lnk as their extension not .xsls. Please right click on one of these shortcuts, select properties, take a screen shot and post it.

What does "the program will think then never open" mean?
0
 
cmdolcetAuthor Commented:
my appologies for any mis communication. In the original question I should of added the description as the desktop shortcut is not working correctly.
0
 
Run5kCommented:
For what it's worth, I still believe that you should follow the instructions on this page and utilize the link found on the subsequent list to restore both the default EXE and LNK file type associations:

Restore Default Windows 7 File Extension Type Associations
0
 
Run5kCommented:
And for future reference, it probably would have solved your previous question, also.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now