?
Solved

A timeout (30000 milliseconds) was reached on a number of services - Windows server 2008 R2

Posted on 2012-04-02
3
Medium Priority
?
14,121 Views
Last Modified: 2012-04-04
Hi,
We are expirencing the following error message for a number of different services:

A timeout (30000 milliseconds) was reached while waiting for a transaction response from the Spooler service.

Other services crashing are:
uxsms
umrdpservice
netman

I read that we need to create a DWORD entry for ServicesPipeTimeout and set it to decimal 60000

I did this and has not resolved the issue.

I ran the following commands and it appears that Spooler may be corrupted or something?

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Administrator.TDS>sc interrogate spooler

SERVICE_NAME: spooler
        TYPE               : 110  WIN32_OWN_PROCESS  (interactive)
        STATE              : 4  RUNNING
                                (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0

C:\Users\Administrator.TDS>sc qc
DESCRIPTION:
        Queries the configuration information for a service.
USAGE:
        sc <server> qc [service name] <bufferSize>

C:\Users\Administrator.TDS>sc qc spooler
[SC] QueryServiceConfig SUCCESS

SERVICE_NAME: spooler
        TYPE               : 110  WIN32_OWN_PROCESS (interactive)
        START_TYPE         : 2   AUTO_START
        ERROR_CONTROL      : 1   NORMAL
        BINARY_PATH_NAME   : C:\Windows\System32\spoolsv.exe
        LOAD_ORDER_GROUP   : SpoolerGroup
        TAG                : 0
        DISPLAY_NAME       : Print Spooler
        DEPENDENCIES       : RPCSS
                           : http
        SERVICE_START_NAME : LocalSystem

C:\Users\Administrator.TDS>sc qc queryex spooler
[SC] OpenService FAILED 1060:

The specified service does not exist as an installed service.


C:\Users\Administrator.TDS>
0
Comment
Question by:Kenzii
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 8

Expert Comment

by:Elmar-H
ID: 37797047
Please try following comand...(without the quotes)

"sc create spooler binPath= %systemroot%\system32\spoolsv.exe start= auto"
0
 

Author Comment

by:Kenzii
ID: 37799781
thanks for reply.
Recieve the below:

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Administrator.TDS>sc create spooler binPath= %systemroot%\system32\spoo
lsv.exe start= auto
[SC] CreateService FAILED 1073:

The specified service already exists.
0
 
LVL 5

Accepted Solution

by:
CarlosDominguez earned 2000 total points
ID: 37800384
1) Can you please dive into the windows event log to find other error or warning messages you could get before the timeout errors.
2) Only these three services failed to start? Is there any service starting (not started) after logon.?
3) Try to log on to the server just after starting, and run the task manager to see if there is any process consuming all CPU.
4) Is there an AV product installed and resident? If so, please try to disable it temporarily.
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are times when we need to generate a report on the inbox rules, where users have set up forwarding externally in their mailbox. In this article, I will be sharing a script I wrote to generate the report in CSV format.
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Suggested Courses
Course of the Month15 days, 2 hours left to enroll

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question