Home Domain Controller and DNS

I created 'DC01-vm', a virtual domain controller running on 2008 R2, on my home network, but I can't attach a windows 7 pro workstation.

Running dcdiag shows no errors.

I have a Vizio router that apparently can't turn off DNS (so far anyway...  and it's also running DHCP).

The error used to be "And attempt to resolve the DNS name of the domain controller being joined has failed. Please verify this client is configured to reach a DNS server that can resolve DNS names in the target domain."

Lately after mucking around, I get "The following error occurred attempting to join the domain "mydomain":  The network path was not found."

I've played around not knowing much about the details of DNS, by pointing my DC at the routers as DNS, and setting the workstations IPconfig so DNS was the DC's IP (192.168.1.7, static).

I would have thought this would be simple and just work!  (Oh, I can ping, and rdp to the controller from the WS).

I think the solution must be dirt simple, but DNS seems to me magical somehow yet.

Any help much appreciated!

David
NeoDavidShepherdAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

motnahp00Commented:
Are you using the FQDN when joining to your domain?

Example: home.internal
0
NeoDavidShepherdAuthor Commented:
Interestingly, when I use 'matrix', I get the errors mentioned. When I used the matrix.us FQDN, the login never appears to enter credentials.

Instead I instantly get 'an active directory domain controller for the domain matrix.us could not be contacted.
0
Darius GhassemCommented:
You should NOT have the router in for DNS the DC should only point to itself for DNS in the TCP\ip properties. All clients and servers should be pointing to DCs for DNS only as well there should be no external DNS servers listed which includes router IP address.
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

NeoDavidShepherdAuthor Commented:
Thanks, I believe I've set it up that way also (except I can't turn OFF the router's actual DNS service).

However, I can definitely go back in and edit the DC's DNS to be sure I took that back out.

Thanks for the help!  Onward and forward.
0
motnahp00Commented:
You have your configures something similar to this?

DC:
IP -> 192.168.1.11
SM -> 255.255.255.0
GW -> 192.168.1.254
DNS -> 127.0.0.1

CLIENT:
IP -> 192.168.1.20
SM -> 255.255.255.0
GW -> 192.168.1.254
DNS -> 192.168.1.11
0
Darius GhassemCommented:
Once you have done the above run ipconfig /flushdns, ipconfig /registerdns, and dcdiag /fix.

Post ipconfig /all from client and DC.
0
RaqueroCommented:
Sounds like a DNS issue as is often the case.

motnahp00's suggestion should work using your current configuration, but consider simplifying the design and removing static configuration.

It is assumed DNS is installed and running on the DC for the domain. You should have a forward lookup zone for the domain (vis. mydomain.local) and a reverse lookup zone for the IP subnet(s) on your network (vis. 0.10.168.192.in-addr.arpa).

Add the router or your ISP DNS server address(es) to the forwarder list on the DC. Disable root hints.

Set the DNS server address for DHCP clients to the IP of the DC (DNS option 6).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
NeoDavidShepherdAuthor Commented:
Yes, thank you...

AND, interestingly, I JUST NOW tried joining the domain with another server2008 VM, and it joined with no problem.

Hmm....
0
NeoDavidShepherdAuthor Commented:
Raquero,

Thank you for that information, I will check into those details now.

Frankly I don't know how to go ABOUT doing what you said:
__________________________________________________________________________
 (You should have a forward lookup zone for the domain (vis. mydomain.local) and a reverse lookup zone for the IP subnet(s) on your network (vis. 0.10.168.192.in-addr.arpa).

Add the router or your ISP DNS server address(es) to the forwarder list on the DC. Disable root hints.

Set the DNS server address for DHCP clients to the IP of the DC (DNS option 6).)
__________________________________________________________________________________

BUT, I will take it as a very good hint and get my google on.

Interesting that the 08 server joined with no problems...

David
0
Darius GhassemCommented:
0
NeoDavidShepherdAuthor Commented:
I spoke too soon...  once the 08 server joined, a reboot said 'no logon servers are available'.

So, it joined, but 'not really'.
0
Darius GhassemCommented:
Post ipconfig /all from both systems.

Make sure you only have one network card enabled
0
NeoDavidShepherdAuthor Commented:
WOOPS, the o8 server worked fine after I released/renewed IP. For some reason it doesn't get the right IP the first bootup.

IP STUFF:

DC
IP   192.168.1.7
MK  255.255.255.0
GW  192.168.1.1
DNS 127.0.0.1   and 192.168.1.1  (the router)


Win7 (non-working)
IP 192.168.1.100
same
same
DNS 192.168.1.1   and 192.168.1.7


Working 08 server now on domain:
IP .5
same
same
DNS   .7     .1     and two internet DNS servers it got from the domain controller I assume
0
Darius GhassemCommented:
Remove the two internet DNS servers.
0
NeoDavidShepherdAuthor Commented:
Thanks dariusg, but those two DNS servers for the internet, are on the o8 server that is working...  it joined the domain fine, and those servers were added by the DC I assume...  if not, it works...

It was the win7 station that failed, and DARNED if the solution isn't just a bit weird.


On the client WS, I put the DNS for the DC, ABOVE the routers DNS...

And that made it work!

I thought I'd done that before, but I must have fat fingered it or something.


Thank you to everyone, I need to figure out who gave me the solution now, or at least the hint that got me there.

MAN it's nice having AD at home.

Thanks again to all, I needed the moral support!

David
0
Darius GhassemCommented:
You should NOT have router IP in DNS this will cause you issues and is why you are having inconsistent issues
0
NeoDavidShepherdAuthor Commented:
By the way, if I take the router IP out of the DC's DNS, the internet is no longer available for the DC...

Leaving it in so far hasn't given me any ill effects, but I'll keep that in mind!
0
Darius GhassemCommented:
0
NeoDavidShepherdAuthor Commented:
Thank you, I didn't see your response before. I'll look into this after I get my project done (fog server).
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.