Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3033
  • Last Modified:

Problem with NFS mount on Windows 2008 server

I am trying to mount an QNAP NFS mount on a Windows 2008 server.


    C:\Users\administrator>showmount -e mynas
    Exports list on mynas:
    /Backups
    /Download
    /Multimedia
    /Public
    /Recordings
    /Tools
    /USBDisk1
    /Usb
    /VM
    /Vmware

Open in new window


Seems ok

However can't seem to get it to mount

    C:\Users\administrator>mount \\mynas\VM V:
    Network Error - 53

    Type 'NET HELPMSG 53' for more information.


    C:\Users\administrator>net helpmsg 53

    The network path was not found.

Open in new window


Probably an obvious one but can't seem to figure it out...
0
Alexandre Takacs
Asked:
Alexandre Takacs
1 Solution
 
dmarinenkoCommented:
Make sure you don't have multiple network ports plugged in and check the share permissions.
0
 
legolasthehansyCommented:
Looks like your Windows host isn't able to resolve the host mynas.
Try on your dos prompt "ping mynas"
0
 
Alexandre TakacsCTOAuthor Commented:
Make sure you don't have multiple network ports plugged in and check the share permissions.
Only one network port
Share permission -> allow *

Looks like your Windows host isn't able to resolve the host mynas.
Then how would showmount -e mynas work ?

Try on your dos prompt "ping mynas"
No problem pinging fine

Thanks
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
Seth SimmonsSr. Systems AdministratorCommented:
That error can occur even if the server is resolvable but the share doesn't exist (or in this case possible typo).

Have you tried //mynas/vm instead?
0
 
Alexandre TakacsCTOAuthor Commented:
Have you tried //mynas/vm instead?

Not accepted (bad path)
0
 
dmarinenkoCommented:
I have seen this happen when not using the real path.
For instance if you are using mount \\mynas\VM   But the share is under \\mynas\usr\VM then it won
t work.  Use the full actual linux machine path.
0
 
Alexandre TakacsCTOAuthor Commented:
Thanks

The actual linux path is /share/VM

Tried

mount \\mynas\share\VM V:
mount \\mynas/share/VM V:

neither is working
0
 
dmarinenkoCommented:
Have you tried using the IP rather than the name?  I would also try that with the full path.  also have you tried a different computer such as an XP machine?
Lastly try disabling the firewall on the 2008 machine.
0
 
Alexandre TakacsCTOAuthor Commented:
Have you tried using the IP rather than the name?  I would also try that with the full path.
 
yes

also have you tried a different computer such as an XP machine?
Is there an NFS client for XP ?

Lastly try disabling the firewall on the 2008 machine.
Not active on said machine nor linux box
0
 
Alexandre TakacsCTOAuthor Commented:
Turns out that "Make sure you don't have multiple network ports plugged" was indeed the problem - wasn't aware of it but someone plugged a cable into the secondary LAN port of the NAS... it was configured to do adapter teaming which somehow doesn't play well with NFS.

Not too sure about the specifics but dis-joining the NICs restored normal NFS functionality.

If anyone cares to comment about it I'm all in...
0
 
dmarinenkoCommented:
Does your switch support LACP (802.3ad)  If not that could have been the issue.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now