Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 608
  • Last Modified:

Windows, route -f

I did a route -f on my Windows machine

Now I can not remote desktop to it

Why did this happen

How do
0
Los Angeles1
Asked:
Los Angeles1
3 Solutions
 
frajicoCommented:
You have deleted the default route and the default gateway.

If you obtain your IP address from a DHCP server, just disable your network connection on the PC and re-enable again. You will obtain again the default gateway and the default route configuration.

If you have a static IP address, you must configure again the default gateway on the PC connection properties, and add the default route throguht the dfault gateway with:

route add 0.0.0.0 mask 0.0.0.0 IP_default_gateway
0
 
theras2000Commented:
-f should get rid of the default gateway/s, so now the machine can't get to the internet anymore.  I assume you're not nearby, so you're going to have to visit the machine.  Have you set a static IP on that machine?  If so, check the TCP/IP settings and see if the gateway is gone.  I suspect that if you just reboot that machine, it'll be back to normal.
0
 
AnuroopsunddCommented:
route -f clears the routing table information. So now you do not have routing information to go to other Networks.
you can restart your machine or disable/Enable your network card.
0

Featured Post

[Webinar On Demand] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now