Can't connect to the MySQL server 5.2.22 community edition

Installed MySQL Server 5.2.22 on a Windows 2008 server. Using the MySQL workbench 5.2 cummunityt edition, the database is working on the server and I can actually log into it via ODBC on the server computer. I have tried to log on the MySQL server on windows 7 client machine using ODBC and it will not see the My SQL server. I have disabled the windows firewall on both the server and the client and I still can not see the My SQL server on the client machine. Openned port 3306 and nothing.
Any suggestions?

Thanks,
Mike
miker454Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Patrick TallaricoFSEP Systems AnalystCommented:
With the ODBC driver, when you try to set up the connection, there should be a test button that you can use before you finish the setup.  What error does it give?
0
miker454Author Commented:
Thanks for the interest. I try to add the ODBC drive MySQL ODBC 5.1 driver version 5.01.08.00 in the client computer and after I enter the connection parameters Data source name, user, password, I can not see any of the databases in the drop down button, and the test fails. (Connection fails: [HY000][ODBC 5.1 Driver]Can't connect to MySQL sever on 'Localhost' (10061). I do the same thing on the server computer and there the databases come up and test is succesfull.

Thanks,
Mike
0
johanntagleCommented:
You can see from the error message that it is connecting to localhost, not the server.  Can you post your connection parameters?
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

arnoldCommented:
You need to first to configure MySQL to listen for tcp/ip connections.
You the have to use the advanced firewall settings and open the port you configured in the prior to allow access from the private/domain network.

netstat -an | grep 3306
See whether MySQL is using the default port.
Use the MySQL configuration tool to make sure it is configured to listen on tcp/ip.
Then make sure you add the user you want to connect with to allow connections from hosts other than localhost.
0
Patrick TallaricoFSEP Systems AnalystCommented:
Make sure the host parameter is the name of the server rather than localhost, or the IP address of the server.
In addition, you may need to grant permission to the user to allow that database to be accessed from a remote computer, (not on the server as localhost)
Generally speaking the syntax for that type of command is:
grant all on database.tablename to 'user'@'computer or ipaddress' identified by 'password';
tablename could be '*' to specify all tables, and computer or ipaddress could be '%' to specify a user from anywhere.
0
miker454Author Commented:
Using the MySQL workbench on the server I created a new New Connection with the name of the client computers as the user (instead of root). I then tried to create the OBDC from the client computer

 Data Source Name: Mike7 (it is the name of the connection on the server)
TCP?IP Server : 192.168.1.180 (servers ipv4 address)
Port: 3306
User: MIKEWIN7 (name of the client computer)
Password: ****** (same password as server connection)

When I hit the test button : Connection Failed: [HY000][MySQL][ODBC 5.1 Driver]
 Host 'MIKEWIN7' is not allowed to connect to this MySQL server.

How do I give this computer permission to connect. I figured once I created a connection that would be enough to give it permission to connect. I specifically used the name MIKEWIN7 as name of the username on the server New Connection. Im still not there.

Thanks for all the suggestions,
Mike
0
arnoldCommented:
Within workbench use the administrator.
Then add the user at any host %. Note using the same username at times leads to trouble do to conflict especially if the user has separate password
Usename@client
Usename@%

If you prefer using the comman line interface.
http://31bit.com/technology/86-mysql-database/302-how-to-grant-remote-access-to-a-mysql-database
Note that after adding users, you need to flush privileges.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
johanntagleCommented:
In addition to @arnold's comment, @stpmt11 already gave you the GRANT syntax above.  You can also refer to http://dev.mysql.com/doc/refman/5.1/en/grant.html for more details.
0
miker454Author Commented:
Thanks to all 3 of you. I feel kind of silly for having problem right off the starting gun but you guys helped me connect to the server. I went to the workbech and added users and priviledges. I did it right from the interface.Thanks Arnold, johanntangle, and stpmt11.


Appreciate it,
Mike
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.