Solved

I Am Now Having My Linux Ubuntu v.11.10 64-bit Operating System Perform Serious Booting And Mounting Issues At Startup?

Posted on 2012-04-02
8
936 Views
Last Modified: 2012-04-05
I am having a serious issue with my Linux Ubuntu v.11.10 64-bit operating system. I am having a /boot failure issues compounded in partition mounting issues.

The cause may be important for you to know, since there are so MANY differentiating individual issues I have been working on with you since this has been happening I cannot recall all of them. I am not going to even begin to assist you here with these individual issues that very could be important factors. We don't need to add 12 paragraphs here. However, ask if you wish if you have a particular question you need to know as you form thoughts.

Also note, I am a newbie with Linux operating systems.

However, I am going to provide you the effects (problems) so you can help me with a solution:

When I boot with my Linux Ubuntu v.11.10 64-bit, I receive for some time now the “GNU GRUB version1.99-12ubuntu5” boot screen with a system boot option “Ubuntu, with Linux 3.0.0-17-generic” (Linux Ubuntu v. 11.10 64-bit) highlighted and ready to boot with a timer set to continue after x (I forgot the exact.) seconds -- maybe approximately 10 seconds on this GRUB boot screen. Yes, this is not typical unless if something is wrong with the booting process I am told. After another 10 seconds with the deep purple blank screen, I get the screen that states centered on the screen: “Ubuntu 11.10” “Serious errors were found while clicking the disk drive for /boot.” “Press I to ignore, S to skip mounting, or M for manual recovery.” Yes, this is absolutely not normal and something is seriously wrong here with Ubuntu booting and loading processes at this point. At different reboot instances over the last few days, I have tried all three letters. M – that requires Linux computer expertise. Forget it. I – doesn't seem to do anything – dead end. So I choose S to 'skip'. My system continues with the booting/loading processes. Now, I get to the Ubuntu login screen. Okay, things at this point are fine. I login successfully. My Ubuntu desktop loads. At the moment the last item finishes loading the desktop, at the bottom center area of my desktop, I get notifications for all my partitions in the form of small black rectangular pop-ups (all appear and disappear in a few seconds) messages indicating that they are now 'mounted'. This is something new this past day of receiving all my partitions on my computer  'mounted' messages.

This whole set of circumstances I have said above has been repetitive every time I turn ON my computer and run Linux Ubuntu v.11.10 64-bit operating system.

So it appears, there is a booting issue with my /boot partition. It seems I have to 'skip' or not mount my partitions in order for my system to boot, after which my system finishes loading, then all my computer's partitions mount automatically.

Questions:

1. What is going on here with this whole scenario I have provided above... ...boot partition? ...'skip' mounting? ...automatically mounting all my computer's partitions after my system has booted and loaded? Please explain.

2. How can I get my system back working properly so the GRUB boot screen, the “Serious errors...” screen, and the mounting messages on the Ubuntu desktop to end? Please explain with steps for resolution -- short of telling me to clean reinstall Ubuntu v.11.10 64-bit. (Yes, lets FIX THIS!)

Please reply.

Thank you!
0
Comment
Question by:Bazingeroo
  • 4
  • 4
8 Comments
 
LVL 20

Expert Comment

by:Daniel McAllister
ID: 37802224
There appear to be filesystem errors on the /boot partition...

Use the I option to boot the system as normally as possible & login as your regular user...
Next, open a Terminal window (first, try the shortcut of Control-Alt-T -- if that doesn't work, try Applications -> Accessories -> Terminal)
Now, we're at command-prompt Linux...

Enter the command "sudo touch /boot/forcefsck" (if you don't know CLI Linux, you press enter at the end of the line)
When prompted for a password, enter YOUR ACCOUNT password -- DO NOT enter the root password, even if you do know it!

Then reboot - and the system should automagically fix the /boot partition during the reboot process.

Let me know how things go!

Dan
0
 

Author Comment

by:Bazingeroo
ID: 37802853
@ it4soho (Dan) & anyone:

Hello. Nice to see you again, it4soho (Dan).

Thank you for your comment.

Okay, I have performed what you said above and it appears after rebooting my Ubuntu system that your answer did not work. It is still doing the same thing each time at Ubuntu system reboots. The only thing I see now is that I do not see all those small windows popping up any longer showing my partitions are mounting on my Ubuntu desktop at the end of my desktop loading. That (those several small mounting partition messages) was happening 'earlier when this all started happening' -- but now it has done away it seems. Other than that, there is no difference in the outcome.

As a note when I selected "I" option you asked me to do, all this does is take me back to the same deep purple blank screen where I get the screen that states (centered on the screen): “Ubuntu 11.10” “An error occurred while mounting /boot.” “Press S to skip mounting or M for manual recovery.”  It shows basically the same information as the previous screen, just eliminates the the "I" option obviously because I selected it on the previous screen and it is removed from the choices.). I had to (like when I was doing it) still press S to skip and get to the Ubuntu login screen.

If you can help me, please do. Anything more aggressive like rebuilding the /boot partition manually IF that would indeed work? Please provide me DETAILED steps if you recommend this as an alternative solution.

Also, please give me some understanding what is going on here in technical terms regardless if you do or do not know the reason or source why this happened?  

Please reply.

Thank you!
0
 
LVL 20

Expert Comment

by:Daniel McAllister
ID: 37803229
If the /boot partition was truly failed, you couldn't boot at all...

Let's try a more aggressive method...

While booted, open another terminal window (Control-Alt-T)
Enter the command "df -h"
 - I am assuming that the /boot partition will NOT show

Next, look at the filesystem table with the command "sudo cat /etc/fstab"

There will be a line in the file that identifies where the /boot partition is supposed to come from (e.g.: /dev/sda1)
Regardless, cut and paste the line (or even the whole file) here...

Next, look at the boot loader with the command "sudo cat /etc/grub.conf"
Cut and paste that entire file here...

The issue is that we want to:
 a) confirm that GRUB and FSTAB are using the same definitions for /boot
 b) determine the hardware device that holds /boot

If you can determine those yourself, great --
 a) if GRUB and FSTAB disagree, trust GRUB and make FSTAB match what's in GRUB
     (why? because GRUB is successfully booting the system!)
 b) if you can easily determine the device name (/dev/sda1, for example) we can force -check and repair the filesystem
     Assuming /dev/sda1, the command will be "fsck -f -C -y /dev/sda1"

I'll await your reply...

Dan
0
 

Author Comment

by:Bazingeroo
ID: 37803695
@ it4soho (Dan):

Hello again. Thank you for your continued help!

I am attaching a screen shop of the Terminal line commands and responses for you to review. I think it is better for you to see it all and not just specific criteria you are asking. I am sorta following you what you are saying and willing to learn, but I am not that comfortable with working in more advanced programming levels with Ubuntu at this time. I think through your example on the steps I need to take will help me understand better what I need to do and what may be going on here.

The screen shot takes into account both requested text command lines.

Please explain when you see what is going on here and what I need to do in detailed steps to resolve this issue.

Please reply.

Thank you!
Screenshot-at-2012-04-03-17-14-4.png
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 20

Accepted Solution

by:
Daniel McAllister earned 500 total points
ID: 37806536
First, my bad on the /etc/grub.conf... that's a RedHat link... and it wouldn't have worked anyway, because it links to the /boot partition -- which isn't mounted! DOH!

But the output you have provided gives me all the data I need to tell you how to fix this...the key is in the output of the 'df -h' -- notice that all of your other filesystems are on the /dev/sdb hard drive... and you're trying to load /boot from /dev/sda1!

So... here's how we fix this...

Step 1 - Boot into normal Ubuntu (Skip option) and open a Terminal window

Step 2 - we need to get the UUID for your /root -- which, I'm guessing, is now at /dev/sdb1 (vs. /dev/sda1)
    Again, I get the idea from the output from 'df -h' that says, for one, that your / filesystem is at /dev/sdb7
    The command to do this is blkid -- and you have to be root to get the response, so enter the command:
       sudo blkid /dev/sdb1
    You should get output that looks like:
         /dev/sdb1: UUID="aaaaaaaa-bbbb-cccc-dddd-eeeeeeeeeeee" TYPE="ext4"

Step 3 - Assuming step 2 gave you an actual UUID, we next need to plant that into the fstab file
    Use the editor of your choice -- since you're not very Linux savvy, I'd suggest gedit
    BUT - you have to edit the file as root -- so use the command:
        sudo gedit /etc/fstab
    You'll get a reasonable text editor you can use to change the fstab file

    PLEASE BE CAREFUL! Changing a line OTHER than the one I tell you to may disable your whole system!

    You will see on the 11th line of the file (remember, you sent me a copy of this file) a line that says:
        /dev/sda1    /boot    ext4    defaults    0    2
    What we want to do is to REPLACE the first part of that line, changing /dev/sda1 to UUID=xxx
    You'll see examples above and below... but you must use the UUID we got above from the blkid program

    NOTE: I STRONGLY URGE YOU TO USE CUT & PASTE!
      A) in the Terminal window, use the mouse to highlight the UUID= part of the blkid output
          highlight everything from the UUID to the ending " on the value, but do not include the last " mark
          To be clear, in the example above, you'll highlight ONLY what I've bolded and underlined below:
               /dev/sdb1: UUID="aaaaaaaa-bbbb-cccc-dddd-eeeeeeeeeeee" TYPE="ext4"
      B) RIGHT-CLICK the mouse and choose COPY
      C) in the gedit window, highlight just the '/dev/sda1' part of line 11
      D) RIGHT-CLICK the mouse and choose PASTE
      E) Use the mouse to move the cursor back to the " after UUID= and REMOVE the " symbol
      F) SAVE the file

Assuming everything went right, reboot and your mount of /boot should be just fine!

Dan
0
 

Author Comment

by:Bazingeroo
ID: 37807971
@ it4soho (Dan):

Hello again.

IT WORKED!!! SOLVED!!! It took 2 Ubuntu reboots in order to get it to smooth out. The first reboot since the fix, I received some odd coding and data quickly come and go under the Ubuntu startup splash screen. Now, it runs like before and is smooth once again. Thank you!!!  

THANK YOU!!!

I have to say this... ...the only thing I still get is the GRUB boot screen “GNU GRUB version1.99-12ubuntu5”) with those selections available that I just hit the ENTER key and I am on my way into the Ubuntu login screen. That GRUB boot screen doesn't seem to go away. I have had that happening for a long time now and at each and every Ubuntu booting session. May I ask why the GRUB boot screen appears each time and doesn't go away on its own?

Is there a way to get rid of the GRUB boot screen and just go from my BIOS startup directly to my Ubuntu login screen when it used to perform like that (normally) a couple of weeks ago after I did a clean install of Ubuntu v.11.04 64-bit (before I did a distribution upgrade)?

So basically, the resolution was that I needed to move the /boot from /dev/sda1 to /dev/sdb1; am I correct?

May I ask what caused the /boot to change to another internal hard drive as you determined ??? This now is the $1 million dollar question??? When I first installed as a 'clean' install of Ubuntu v. 11.04 64-bit a couple of weeks ago, I had only ONE internal physical hard drive connected and powered to my motherboard. Therefore all the required Linux Ubuntu partitions were setup ALL ON THAT ONE DRIVE (/dev/sdb). So what caused it to change????????????? What made Ubuntu decide to go move the /boot onto another hard drive??? Yes, I did do a upgrade distribution from v.11.04 to 11.10, but I do not think that is what caused the /boot to move to another physical hard drive?????????????  

I also have one internal physical hard drive that has Windows 7 64-bit (a system drive/partition) with the Windows bootloader files with that hard drive. My Windows 7 was clean installed several months ago. NOTE: Windows 7 and Linux Ubuntu do NOT share the same booting files, they are separate – obviously when I installed Ubuntu when I only had ONE internal hard drive connected. Since I have reconnected the data (SATA) cables and the power connector to that drive, and have been switching back and forth between Ubuntu and Windows -- could this caused Linux/Ubuntu to rearrange the organizational booting structure from what was originally established when I did a clean install of Linux Ubuntu? (Also, I see since around the same time, the GRUB boot screen start to appear when I booted in Ubuntu. However the GRUB boot screen started before this issue you have fixed for me and the GRUB boot screen STILL present AFTER this fix.) Furthermore, I even connected  (data/power cables) to some more of my internal hard drives I use for data storage... ...while switching back and forth between Windows 7 and Ubuntu. Could this have rearranged the organizational booting structure from what was originally established when I did a clean install of Linux Ubuntu too?

If this is true, then once you install, you had better have all your internal hard drives where you want them (That is all of them connected and finalized – no changes or swapping) PRIOR to a clean install Linux Ubuntu or your going to have Linux/Ubuntu booting issues like the one you just fixed for me. Am I correct to say this????

...and if that is true (what I just said)... ….then I can summarize that Unix/Linux/Ubuntu is a control freak 'over its flock' and has to have everything in its fixed place at all times (drives and partitions) and has to account for everything (drives and partitions) at all times. Any changes by adding or subtracting internal hard drives can cause Unix/Linux/Ubuntu to go crazy. I do not seem to have any issues with changing or switching internal hard drives with Windows 7 from past experience – it seems as if Windows treats each internal hard drive 'separately' and if it goes missing (like unplugged) or one is added (plugged back in); Windows really does not care about redirecting the drives/partitions. When you plug back in an internal hard drive in Windows you used before, it seems 'to know from before' and reassigns it its old place. It seems Unix/Linux/Ubuntu has detected changes, it has to rename/reassign or relabel the drives/partitions once an established drive/partition is removed. I may be wrong, but it sure seems that way. Please comment.

...but being a 'control freak' has its benefits too... ...'it knows where to go' on the grand scheme of its full system resources in order to make the correct adjustments necessary to get things at least partially operational and functional again until it can be fully fixed like here.  

I am not being oppressive, cynical, or offensive in any way with my comments. I am trying to be objective, logical, and rationalize what the cause of this problem was.

Please reply to all my comments. I would love to hear what you have to say.

Thank you!
0
 
LVL 20

Assisted Solution

by:Daniel McAllister
Daniel McAllister earned 500 total points
ID: 37811769
First of all, if you followed my directions, your /boot can now be anywhere (/dev/sda, /dev/sdb, or even /dev/hda for that matter! -- that's a whole different drive technology!) That's the whole reason for using the UUID instead of the hard-coded device name.

Next, you mentioned that you originally installed with just one drive (a Ubuntu drive) -- in which case, all of your Ubuntu files (partitions) were on /dev/sda
BUT then you said you added a Windows 7 drive... and apparently, you're dual-booting by swapping the cables back and forth to choose an appropriate boot drive -- which is a VERY BAD solution! (Both Windows 7 and Ubuntu have the ability to give you a boot-time option to choose to boot off of one drive or the other - playing with cables -- even SATA cables -- every so often is just asking for trouble!)

However, you are correct in noting that adding the Windows 7 drive essentially moved the Ubuntu drive to /dev/sdb (where it was originally /dev/sda). However, the fact that your /boot was hard-coded to /dev/sda1 is unusual -- in fact, I've NEVER seen it result in that from a Ubuntu installation. (That doesn't mean it can't happen -- I don't install that many Ubuntu systems! I'm more of a RHEL guy because I work mostly on servers... I use Ubuntu for desktop linux!)

So, to directly answer your question about making sure your hardware is where it is going to be at install time is not really true -- and I cannot explain why your system had /boot at a hard-coded hardware location unless someone played with it, or something very strange happened during the install. But after the steps we took, your Ubuntu is now more "normal" in that all of the filesystems are identified by their UUID... which means that they can be anywhere on your system and everything will work just fine.

Again, I cannot say HOW your system got corrupted -- only that it wasn't really that hard to fix once it was identified (and it wasn't really that hard to identify either!).... and the corruption I speak of is the hard-coding of /dev/sda1 in the /etc/fstab file... fortunately, your boot loader was just fine otherwise you couldn't have booted at all!!

I hope this answered your questions! I'm glad you got it working!

Dan
IT4SOHO

PS: The fact that you have boot options is not uncommon when doing a disk-based upgrade on Ubuntu.
Here is a link to help you clean it up.
0
 

Author Closing Comment

by:Bazingeroo
ID: 37814880
@ it4soho (Dan):

Hello again. I am now closing this question/thread. This is one of those true 'learning questions/threads' I get once-in-a-while that I truly appreciate and cherish. Thank you very much taking the time and sharing your wisdom in helping me resolve this issue!!! I have learned a lot!!!

I am awarding you the majority of points to your third comment since you fixed my issue with that comment obviously -- that is the Accepted Solution. Your last or forth comment I am awarding a small amount of points as the Assisted Solution since the information you convey is very important and applicable to this question/thread and also inclusive to undertand your actions in your previous comment.

Again, thank you very much!!!
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
1. Introduction As many people are interested in Linux but not as many are interested or knowledgeable (enough) to install Linux on their system, here is a safe way to try out Linux on your existing (Windows) system. The idea is that you insta…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now