Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1720
  • Last Modified:

Exchange 2010 - Change NDR message format to HTML?

Exchange 2010 lets me put HTML tags into custom DSN messages but when those messages get sent in an NDR, the NDR is sent in plain text and the HTML is lost.

Is there a way to make the default format of my NDR messages HTML and not plain text?

Thanks.
0
gateguard
Asked:
gateguard
  • 5
  • 5
1 Solution
 
sivanovCommented:
PLease check if you are ussing valin DSN html tags:

http://technet.microsoft.com/en-us/library/bb125135.aspx

what about if the only html in the NDR is <b> hello </B>
Svet.
0
 
gateguardAuthor Commented:
I tried just a single word surrounded by the bold tags as in your example but it doesn't matter because the message itself is delivered as PLAIN TEXT so tags get ignored.

My question is:

How can I set the default delivery of NDR messages in my Exchange 2010 organization to be HTML mail messages, not plain text messages?
0
 
sivanovCommented:
as far as i know NDR are just one of the DSN messages.

the link above says:


"By default, Exchange 2010 sends HTML DSN messages, but you can configure whether Exchange 2010 sends HTML DSN messages to internal senders, external senders, or both.
To configure this behavior, modify the InternalDsnSendHtml parameter and the ExternalDsnSendHtml parameter with the Set-TransportServer command.
If the InternalDsnSendHtml parameter is set to $false, Exchange 2010 suppresses HTML tags in DSN messages sent to internal senders. If the ExternalDsnSendHtml parameter is set to $false, Exchange 2010 suppresses HTML tags in DSN messages sent to external senders. "

might be a hint tocheck the parameter mentiond above.
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
gateguardAuthor Commented:
I'm getting errors trying to modify these.

How do I read these parameters to see what they are set at right now?
0
 
gateguardAuthor Commented:
[PS] C:\Users\test\Desktop>Set-TransportServer  -Identity server1 -InternalDsnSendHtml $True
A positional parameter cannot be found that accepts argument '-InternalDsnSendHtml'.
    + CategoryInfo          : InvalidArgument: (:) [Set-TransportServer], ParameterBindingException
    + FullyQualifiedErrorId : PositionalParameterNotFound,Set-TransportServer
0
 
sivanovCommented:
hmmm

do you need the parameter "-identity" - i read that is is for multi-tenant hosting envirement ?
if yes most probably you need to execute to commands:

C:\Users\test\Desktop>Set-TransportServer  -Identity server1

C:\Users\test\Desktop>Set-TransportConfig -InternalDsnSendHtml $true

 
please check the linkg below


http://technet.microsoft.com/en-us/library/bb123506.aspx

http://technet.microsoft.com/en-us/library/bb124151.aspx
0
 
gateguardAuthor Commented:
This is what I get and the result in the actual NDR doesn't change... still a text message:


[PS] C:\Users\test\Desktop>Set-TransportServer  -Identity SERVER1
WARNING: The command completed successfully but no settings of 'SERVER1' have been modified.
[PS] C:\Users\test\Desktop>Set-TransportConfig -InternalDsnSendHtml $true
WARNING: The command completed successfully but no settings of 'Transport Settings' have been modified.
[PS] C:\Users\test\Desktop>
0
 
sivanovCommented:
well this should mean that the "-InternalDsnSendHtml" is set to  "$true" as expected by default.

do you exoperience this issues only for NDRs or with other types of the DSNs?

could you show a sample how you prepare the DSN ?
0
 
gateguardAuthor Commented:
I'm giving up on this one.  I personally don't care about the formatting, one of the managers here did.  The messages are otherwise doing their job and that's all I care about.

Sivanov, I thank you for all your help and I learned a lot from you working on this.
0
 
sivanovCommented:
you a very welcome
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now