how to add NoteBoard webpart on TeamSite in sharepoint 2010 Enterprise ??

Hi,

I want to add Note Board Webpart (available in "Social Collaboration" group) in sharepoint 2010 Team Site page.

But I can see only 2 webpart there-->Site Users & User Tasks (only 2) ?

Where are rest of web parts??

How can i add note-board webpart there on page??

Thanks a lot  ??
sharepointDepotAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

InderjeetjaggiCommented:
If the note board web part is not available, you will need to activate the feature PortalLayouts.  Use the following powershell command:
Enable-SPFeature –Identity PortalLayouts –url <site url>

I followed below article to resolve your issue:
http://donalconlon.wordpress.com/2011/03/02/adding-the-social-note-board-to-a-sharepoint-blog/

Regards,
Inderjeet
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sharepointDepotAuthor Commented:
Thanks indrajeet,

it looks cool,

I tested it but unfortunately it gives me error.

I have manually activated sp features but it still gives me that error shown in screen shot .

noteboard error for portallayout feature
Thank you
0
sharepointDepotAuthor Commented:
Hi,

I restarted the machine and then this new error saying "already activated"

see screen feature already activated
Just to inform....this is i upgraded from moss 2007 to sp 2010.

so i used sql database restored and clicked "Visual Upgrade"  from site settings.

then it ran fine till now...but this requirement it stucks.

Any idea please...
0
sharepointDepotAuthor Commented:
Hi,

First i used Disable-SPFeature –Identity PortalLayouts –url <site url>

then  used Enable-SPFeature –Identity PortalLayouts –url <site url>

done
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.