• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 818
  • Last Modified:

Tag Native VLAN on Cisco 2801

Hi

We have two Cisco 2801 that connects two offices.

We where running the traffic over serial interface but now we got a new provider of the comunication line. They could only deliver a line with TCP/IP so we had to change to fast ethernet on both routers.

They say that we have to tag the native VLAN 1 traffic over the line.
Must we use Trunks or Subinterfaces or what?

We have tried to change the configuration with no success.

How do we set this up correctly ?

The cisco 2801 is running 12.4(16a).
0
IntesyNordic
Asked:
IntesyNordic
  • 4
  • 4
2 Solutions
 
Nayyar HH (CCIE RS)Network ArchitectCommented:
If they say you should tag vlan 1 then use sub-interfaces

Check your device can support the configurations below; Its the latter config you need to support


Traffic sent across VLAN1 below is NOT tagged

interface FastEthernet0/0.1
 encapsulation dot1Q 1 native



Traffic sent across VLAN1 below is tagged

interface FastEthernet0/0.1
 encapsulation dot1Q 1
0
 
IntesyNordicAuthor Commented:
The router adds native by itself when we enter the command encapsulation dot1Q 1.
We can't see any other commands in the running-config that have any effect on this.

Any ideas?
0
 
Nayyar HH (CCIE RS)Network ArchitectCommented:
I thought you might get that behaviour - I'm afraid you may not be able to send tagged frames out on VLAN 1

However on a switch such as the 3550 you can achieve this by the command "vlan dot1q tag native"

So can you introduce a switch between the router and the service provider?

Before proceeding further I would ask the SP some questions?

Why do they require data on VLAN 1 to be sent tagged? Could they not present the service to you on any other VLAN such as VLAN2 (tagged)? [ Reason: your equipment doesn't support sending tagged frames on VLAN1]
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
IntesyNordicAuthor Commented:
The SP said that because of the hardware platform in one of the locations they had to have tagged traffic thru the line. We can't argue with them on that.
We will look into new routers or switches.

Thanks for the help.
0
 
IntesyNordicAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for IntesyNordic's comment #37806271

for the following reason:

Feedback answer.
0
 
Nayyar HH (CCIE RS)Network ArchitectCommented:
Post ID: 37805833 provides a solution/workaround - some points should be awarded for this post at least
0
 
IntesyNordicAuthor Commented:
Sorry about that, I'am new to this. How do i set points.
0
 
Nayyar HH (CCIE RS)Network ArchitectCommented:
No problem - I think you should have the option of accepting a post as the solution and then awarding points
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now