user could not log onto the ESXi because of the permission

I just created the new user with root permission. However, he could not log onto the ESXi host using vShpere. He got this error message

The vsphere client could not connect to 10.10.10.40. You do not have permission to login to the server 10.10.10.40.

Please advice me .
Thanks,
dongocdungAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

GeodashCommented:
Are you using AD authentication?
coolsport00Commented:
Is that the IP of the host or to vCenter? After you create a User, you have to assign the user "Permission". Click the Permission tab and add that user the permission to log into either the Host or vCenter.

~coolsport00
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Have you also granted permission for this user, to the Server Object in the vSphere Client, just creating a user does not give them access, unless you assign the user permission to the object.

e.g. top of the tree
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

coolsport00Commented:
Click on 'Host' in upper left, then permission tab on right. Then, click the 'whitespace' to 'Add Permission' of this new user.

~coolsport00

Host Permission
dongocdungAuthor Commented:
I assigned the root permission to this user but he could not log in. This ESXi is not connected to the network yet.
coolsport00Commented:
If the host can't be 'seen' on the network, but only your workstation, for example,, then no one but you will be able to log in until you get IP settings configured in the Configuration tab.
dongocdungAuthor Commented:
I get into the Configuration tab, but I don't know where I can set the IP Address.
coolsport00Commented:
Under Networking in the 'Hardware' box. You'll basically configure a VMkernel port as a "management" network. Or, maybe an easier way to do so is to connect to your host console, the DCUI (direct console user interface) and configure your host IP settings there (pressing F2, then log in with 'root').

~coolsport00
dongocdungAuthor Commented:
I see the VmKernel has IP address already.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Check Management Network IP Address
coolsport00Commented:
Ok..if you're using 4.x, it will be a "mgmt" network, whereas if you're using 5.x, it'll be a VMKernel port with "Management"...VMware kinda consolidated things a bit.
dongocdungAuthor Commented:
What do I do now?
Thanks,
coolsport00Commented:
Have your user use that IP in his/her vSphere Client to try and log into the Host...
dongocdungAuthor Commented:
Yes, he did but got the permission error above.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
did you assign permissions to server object?
coolsport00Commented:
See my screenshot above and how I have the actual host highlighted, then the Permissions tab is accessed on the right. So, if I were to expand my host (virtual01), there would be VMs below it (or Resource Pools and VMs). Those are all what VMware calls "objects" in the object or naviagation tree there on the left side. You can set permissions at any level. And those permissions, when granted on a certain level, are at that level and propagate downward. Since you want this user to have access to your host, you grant it at the host level. If you want to forbid access at any given level below the object where access is granted, you assign the user in question the 'no access' right/permission on a given object.

~coolsport00

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dongocdungAuthor Commented:
I granted him a "root level" to a host but he could not log on to the host using the v Sphere client.
dainjahCommented:
Post your screenshots. You must have done something wrong that can't be explained using text-mode only.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.