Solved

SQL connection Issues

Posted on 2012-04-03
7
232 Views
Last Modified: 2012-04-16
Trying to connect to SQL server 2008 r2 and i get the attached error message. Server is 2008 r2 Express, client is Windows 7 Pro. Both Firewalls have been disabled.
Untitled.jpg
0
Comment
Question by:nidul2004
7 Comments
 
LVL 15

Expert Comment

by:deepakChauhan
ID: 37802693
0. make sure tcpip is enabled

1. Use 'ping server' to test the network.
2. Use 'telnet server 1433' to ensure that the SQL Server is listening
on the port.

3. Check the Net-Library protocol configured by using 'Client Network
Utility'
on the client. Are they supported by the SQL Server? If you use Named
Pipes,please try to change it to TCP/IP.

4. Add an entry in the hosts file on the
client machine.
0
 

Expert Comment

by:expert9
ID: 37802704
you can try either of these solutions

1. Add an entry in the hosts file on the
client machine.
2. Check the Net-Library protocol configured by using 'Client Network
Utility'
on the client. Are they supported by the SQL Server? If you use Named
Pipes,please try to change it to TCP/IP.
3. Use 'ping server' to test the network.
4. Use 'telnet server 1433' to ensure that the SQL Server is listening
on the port.
5. Try again.

or

Change the dns server address form automatically to dedicated one(Network Connection>TCP/IP Protocol), then ping again
0
 
LVL 15

Expert Comment

by:deepakChauhan
ID: 37802721
other one but dont  work everytime

1. run sqlserver as administrator

2. click on option button on the login screen  and change default to tcpip in the network protocol section drop down box
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:nidul2004
ID: 37802915
0. TCPIP and Named pipes are enabled
1. Can ping yes
2. Can not telnet to port 1433.

My SQL Server Agent is set to auto, but will not stay started.
0
 
LVL 8

Expert Comment

by:POracle
ID: 37818472
Your port might be block or sql server might listening to other port.

Read this article, it explain in detail
http://support.microsoft.com/kb/823938

Let us know if your prob. still not resolved
0
 

Accepted Solution

by:
nidul2004 earned 0 total points
ID: 37834859
Port was open, but for some reason SQL browers service was not started. Set to automatic, problem solved.
0
 

Author Closing Comment

by:nidul2004
ID: 37850379
Solved own problem
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article we will get to know that how can we recover deleted data if it happens accidently. We really can recover deleted rows if we know the time when data is deleted by using the transaction log.
Load balancing is the method of dividing the total amount of work performed by one computer between two or more computers. Its aim is to get more work done in the same amount of time, ensuring that all the users get served faster.
Viewers will learn how the fundamental information of how to create a table.
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

919 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now