Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Ubuntu 10.10 & Open Ports

Posted on 2012-04-03
9
Medium Priority
?
498 Views
Last Modified: 2012-04-19
I need to open the SSH port on an Ubuntu 10.10 (Maverick) machine.  How do i do this?
0
Comment
Question by:deklinm
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
9 Comments
 
LVL 3

Accepted Solution

by:
WebF00L earned 668 total points
ID: 37802680
sudo apt-get install openssh-server

IF you have ufw active you might have to add

sudo ufw allow 22

//WebFooL Untangle.com Evangelist
0
 

Author Comment

by:deklinm
ID: 37802697
SSH is already installed.  I need to open the port to allow the traffic for it.
0
 
LVL 11

Assisted Solution

by:legolasthehansy
legolasthehansy earned 1332 total points
ID: 37802745
Follow the instructions in this link if you using ufw as the firewall.

http://beginlinux.wordpress.com/2008/11/23/ubuntu-810-uncomplicated-firewall-gui/
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 

Author Comment

by:deklinm
ID: 37802868
sudo: ufw: command not found
0
 
LVL 11

Expert Comment

by:legolasthehansy
ID: 37802904
Try "apt-get install gufw" to install the application using apt-get
0
 

Author Comment

by:deklinm
ID: 37802911
if gufw isnt installed then can't I just edit a port config file?
0
 
LVL 11

Assisted Solution

by:legolasthehansy
legolasthehansy earned 1332 total points
ID: 37802931
gufw is a graphical utility to edit your firewall rules. It is just easier. If you prefer the command line try this, "ufw allow 22"

See if you are able to "telnet localhost 22" first to see if the service is up and running.
Next try telnet host 22 from another machine before and after running ufw allow 22

Good luck
0
 

Author Comment

by:deklinm
ID: 37802938
# ufw allow 22
-bash: ufw: command not found

I can telnet to the machine now.  The problem is the machine will only accept telnet connections from one specific IP address
0
 
LVL 11

Expert Comment

by:legolasthehansy
ID: 37802955
So.. it shouldn't be your firewall that is blocking. Have you checked /etc/ssh/sshd_config file and see if there are rules set such as (allow). Also check /etc/hosts.allow and /etc/hosts.deny files.
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Suggested Courses

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question