Solved

554 5.4.7 [internal] exceeded max time without delivery

Posted on 2012-04-03
8
14,812 Views
Last Modified: 2012-04-25
Hello,

I have an exchange server in one of our clients site, it works fine except one issue:

One sender from out of the org. when he send emails to our server he got the NDR

554 5.4.7 [internal] exceeded max time without delivery

I think it is a DNS or routing problem in their side, but I need a confirmation for that.

While I am troubleshooting I gotin mxtoolbox:

220 ****************************************
Warning - Reverse DNS does not match SMTP Banner

Is this be a problem ? if not, what would the impact of this warning on the exchange server ?

any help would be appreciated.

Thanks in advance.
0
Comment
Question by:Suliman Abu Kharroub
  • 4
  • 3
8 Comments
 
LVL 12

Accepted Solution

by:
Deepu Chowdary earned 167 total points
ID: 37803248
Once check the inbound and outbound mailflow through TEST EXCHANGE CONNECTIVITY.
Generally this  Reverse DNS does not match SMTP Banner when you dont have a rdns record at ISP end.
Ask the Internet service provider to create a RDNS record pointing to our IP and our server.
0
 
LVL 21

Assisted Solution

by:Papertrip
Papertrip earned 333 total points
ID: 37803249
It's possible that is causing delivery issues to your server, it really depends on how the sending server is configured to treat such a mismatch.  If it's sensitive to that, then it could very well be the problem.

When it comes to you sending mail however that can also be an issue.  Make sure you have a PTR record for your sending IP with a matching A record for it's FQDN and if possible change the SMTP banner to match.  This should be done regardless of this particular problem.
0
 
LVL 23

Author Comment

by:Suliman Abu Kharroub
ID: 37803272
>>"It's possible that is causing delivery issues to your server, it really depends on how the sending server is configured to treat such a mismatch.  If it's sensitive to that, then it could very well be the problem.

How can this problem be fixed up please ? I mean the warning message.

rDNS is already  configured and created in the ISP dns servers.
0
 
LVL 21

Assisted Solution

by:Papertrip
Papertrip earned 333 total points
ID: 37803287
If you are certain you have a PTR record for your sending IP along with a matching A record, then you need to configure Exchange to use that name in it's SMTP banner / HELO response.

You can check the PTR for your IP at http://mxtoolbox.com/ReverseLookup.aspx
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 23

Author Comment

by:Suliman Abu Kharroub
ID: 37803298
>>you need to configure Exchange to use that name in it's SMTP banner / HELO response.

Where should this be done please ? Send connector, default receive connector or client receive connector ?

Thanks for your help.
0
 
LVL 21

Expert Comment

by:Papertrip
ID: 37804304
Configure SMTP banner Exchange 2003

1. Open Exchange system manager.
2. Expand your administrative group (”First administrative group” by default).
3. Expand Servers.
4. Expand "YourServersName".
5. Expand Protocals container.
6. Select SMTP container.
7. On the right window, right click the Default SMTP virtual Server (Or the name you set your SMTP Server) and select Properties.
8. Select the Delivery Tab.
9. Click the Advanced button.
10. Under the Fully Qualified Domain Name (FQDN) type mail.yourdomain.com (The A/Host record you created in DNS for your mail server)
11. Click Apply and OK again to accept the changes

Configure SMTP banner Exchange 2007/2010

1. Open the Exchange management console.
2. Select the Organisation Configuration container.
3. Select Hub Transport container.
4. On the right select the Send Connectors tab.
5. Right click your send connector and select properties.
6. On the General tab under the Set the Fully Qualified Domain Name (FQDN) this connector will… type the A record domain name you created. Which in our case is mail.yourdomain.com. Click OK.
7. Under the Server Configuration container click the Hub Transport container.
8. In the Right window Select the properties of the Receive Connector under Receive Connectors tab.
9. On the General tab under the Set the Fully Qualified Domain Name (FQDN) this connector will… type the A record domain name you created. Which in our case is mail.yourdomain.com. Click OK.


http://community.mxtoolbox.com/forums/viewtopic.php?f=9&t=13143
0
 
LVL 23

Author Comment

by:Suliman Abu Kharroub
ID: 37805941
why I need to do it in the send connector ?

Which receive connector, default or client ?
0
 
LVL 23

Author Closing Comment

by:Suliman Abu Kharroub
ID: 37891267
Thanks all!
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Suggested Solutions

Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video discusses moving either the default database or any database to a new volume.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now