Sharepoint 2010 - 'Contribute - No Delete' Access

I'm experiencing an issue with Sharepoint 2010 when I select a Document Library and stop inheritance of permissions from parent folders.
If I try to add a user to that Document Library and select the 'Contribute - No Delete' permission to it, the user cannot see the Document Library location at all.
However, when I change that user's permission to the full 'Contribute' permission, the Document Library appears in the Documents List.
For general reference, we're using Sharepoint 2010 and the company browses using IE8.

Does anyone have a suggestion as to why 'Contribute - No Delete' and 'Contribute' would affect the view of a Document Library? I would imagine both permissions have at least read access.

Thanks.
MayogroupAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Hello,

how exactly have you set up the "contribute - no delete" permission level? Have a look at this article about setting up permissions to contribute, but not delete. There is a special mention of the crucial permission to check "View application pages"

Have a go with that suggestion and report back.

cheers, teylyn
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MayogroupAuthor Commented:
Thank you Teylyn. I had a look at both 'Contribute' and 'Contribute - No Delete' permission levels side-by-side and the only difference was the exact permission you stated, namely 'View Application Pages'.

Gave that a tick and tested it to work perfectly. Thanks for your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.