exhange2007 problem

i ahve a problem in exchange 2007
one user has two mail addresses
the 2nd mail address was (for example:  mail2@test.com)
now i removed that user account
now i want to give the same mail address (mail2@test.com) to be the 2nd mail address to another user.
i did that already but when i try to send any mail from outside(yahoo for example)to that email address(mail2@test.com) then it gives me (failure bounce message).
the failure bounce mesage is:
Below this line is a copy of the message.

Received: from [] by nm14.bullet.mail.ird.yahoo.com with NNFMP; 04 Apr 2012 07:38:58 -0000
Received: from [] by tm12.bullet.mail.ird.yahoo.com with NNFMP; 04 Apr 2012 07:38:58 -0000
Received: from [] by omp1022.mail.ird.yahoo.com with NNFMP; 04 Apr 2012 07:38:58 -0000
X-Yahoo-Newman-Property: ymail-3
X-Yahoo-Newman-Id: 709624.95704.bm@omp1022.mail.ird.yahoo.com
Received: (qmail 74308 invoked by uid 60001); 4 Apr 2012 07:38:58 -0000
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoo.com; s=s1024; t=1333525138; bh=25bLHZTVAZtnNfiYFhefV4DcD+Tdbb/ME48PXgJh9t0=; h=X-YMail-OSG:Received:X-Mailer:Message-ID:Date:From:Reply-To:Subject:To:MIME-Version:Content-Type; b=Xiq7lOhG6UGjn9TwLNgNtQm7PHwGBX+2/CyjAGzTXNkBMyF7kaHwswtla1rEV5GQBjEIuO7YmA6Ap8x8zjv3bxozprW8jjflZMh7R2wIWsQ1G75N5gNikZs6o/HWuKBa0rfU/KKMvl78zVpySeIOjr8TifP/FrwzeHZiFB9mM5k=
DomainKey-Signature:a=rsa-sha1; q=dns; c=nofws;
  s=s1024; d=yahoo.com;
X-YMail-OSG: CZ9XSoAVM1n7mLeMXc_OfhsmhVyVFHrkosHQL_AhahAf5Lg
Received: from [] by web29306.mail.ird.yahoo.com via HTTP; Wed, 04 Apr 2012 08:38:58 BST
X-Mailer: YahooMailWebService/
Message-ID: <1333525138.71720.YahooMailNeo@web29306.mail.ird.yahoo.com>
Date: Wed, 4 Apr 2012 08:38:58 +0100 (BST)
From: Hossam Hassan <hosdoda@yahoo.com>
Reply-To: Hossam Hassan <hosdoda@yahoo.com>
Subject: test to springs
To: "mail2@test.com" <mail2@test.com>
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="1621457529-768732684-1333525138=:71720"

Content-Type: text/plain; charset=us-ascii

Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: quoted-printable

<html><body><div style=3D"color:#000; background-color:#fff; font-family:ti=
mes new roman, new york, times, serif;font-size:12pt"><div></div></div></bo=

how can i solve that problem please?
Who is Participating?
vishalvasuConnect With a Mentor Commented:
1.Open Server Management, and expand Advanced Management, First Organization Exchange, Recipients and select Offline Address Book.

2.On the right hand side you'll see the Default Offline Address List, right-click it and choose Rebuild.

Moreover, a series of articles on http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/offline-address-book-part1.html is a good resource.
Give some time for replication to complete...
Muzafar MominCommented:
restart the transport service in Hub Transport for faster replication with no impact at users end
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

alfadhelAuthor Commented:
i restarted the Transport service many times but still no change
any other solution please?
alfadhelAuthor Commented:
any solution pleaseeeeeeeeeeeeeeee/???????
Recreate the mailbox , This will be the easeist and fastes solution..

You can export to PST file and than import if you need the data.
alfadhelAuthor Commented:
no hope, the problem still, any solution???????
Can u send to the 2nd E-Mail Address internally?
Are you using an EDGE server in your setup or are the emails delivered directly to the Exchange server? Have you configured any Anti-Spam settings on the server which bounces emails which are sent to those email ID's which are not in GAL?
alfadhelAuthor Commented:
i noticed something
i created new user account with new mailbox
when i try to send email to it from outsdie it is giving the same bound message.
when i try to send an email internally to him then it is working fine.
i tries to update the global address list by the command
update-global-addresslist -identity "my global address list" -DomainController my-dc
then it gives me that error message:
WARNING: The recipient "mydomain/Microsoft Exchange System
Objects/Offline Address Book - \/o=mydomain\/cn=addrlists\/cn=" is
 invalid and could not be updated.
WARNING: The recipient "mydomain/Microsoft Exchange System
Objects/Offline Address Book - First Administrative Group" is invalid and could
 not be updated.
WARNING: The recipient "mydomain/Microsoft Exchange System
Objects/Schedule+ Free Busy Information - First Administrative Group" is
invalid and could not be updated.

anyone know how to solve that problem???
my problem means that any new user can't receive mails from outside because of not updating the global address list.

any help please
Exactly something which I thought would be blocking the external emails. Try rebuilding the OAB.
alfadhelAuthor Commented:
how i can rebuild the OAB (offline address book) without interrupt the work?
alfadhelAuthor Commented:
any suggestion?
any solutions pleeeeeeeeeeeeeeease?
Turn off cached exchange mode on that client, that should force an OAB update.
Do you have some sort of anti-spam appliance or service outside of your exchange org?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.