certain emails stuck in queue

Greetings,

I have emails to a couple of domains stuck in queue. the email addresses are typed correctly. I am unable to telnet into the servers. all other email is flowing normally. this is exchange 2003 sp2.

any ideas greatly appreciated.
LVL 7
king daddyAsked:
Who is Participating?
 
DrDave242Commented:
The research I've done so far indicates that this can be caused by...a whole bunch of things, as you can see in this old thread:

http://forums.msexchange.org/Cannot_send_mail_to_certain_domains/m_180038400/tm.htm

Are your PTR and SPF records in order?  Do you have antivirus software on your Exchange server?  Is it behind a firewall?  Those are just a couple of things to look at, since you've already done a blacklist check.  It looks like it may take a while to nail this one down, unfortunately.
0
 
Alan HardistyCo-OwnerCommented:
Can you telnet to other servers happily?

If you can to others and can't to these - it suggests that they may be blocking you, or your ISP might be blocking you selectively, which would be unusual!
0
 
king daddyAuthor Commented:
yes. Also, I had the incorrect mail server for bellsouth.net. I found one on their support page detailing how to set up POP clients. I used that address and port 995 (which they specify) and I was able to connect but only get a blank command prompt. when I begin to type EHLO, it stops and the cmd line comes back. mxtoolbox shows us on no blacklists.
0
On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

 
DrDave242Commented:
Are these large domains that you're having trouble mailing, or small mom-and-pop shops?  In other words, is there any chance that the problems could be on the other end?
0
 
king daddyAuthor Commented:
it is bellsouth.net, which is now AT&T, which is apparently somehow associated with yahoo according to the email client set up instructions for bellsouth.net email addresses. there are a few other domains stuck in queue, one a large state university law school, another is a local law firm. users have sent me this NDR:

     
            This message was rejected due to the current administrative policy by the destination server.  Please retry at a later time.  If that fails, contact your system administrator.
            <mail.mydomain.com #4.3.2>
0
 
king daddyAuthor Commented:
the law school one just went through after I forced the connection through ESM.
0
 
king daddyAuthor Commented:
the records are in order. the gracious other poster here, alanhardisty, confirmed that they looked good when he previously helped me with another exchange issue.

it is behind a firewall but all other email flows OK. antivirus is disabled and has been for quite sometime.

thanks for your help
0
 
Alan HardistyCo-OwnerCommented:
What Service Pack / Rollup have you got installed?  Are you up-to-date?
0
 
king daddyAuthor Commented:
Sp2 with all updates
0
 
Alan HardistyCo-OwnerCommented:
Which DNS forwarders are you using on your DNS Server Properties?  Your ISP's / Googles / other random ones?
0
 
king daddyAuthor Commented:
Was ISP but changed but removed so it would pull from server. I'll confirm this as I just changed yesterday while troubleshooting this.
0
 
Alan HardistyCo-OwnerCommented:
Should be ISP's DNS servers but you can add others too.  As long as you have something there it is good news.
0
 
king daddyAuthor Commented:
just confirmed both DNS servers have (2) ISP DNS servers configured as forwarders (both TW). I misunderstood earlier and thought you were referring to the DNS servers configured on the exchange server.
0
 
Alan HardistyCo-OwnerCommented:
Okay - can you restart the DNS Server Service and check your queues please.
0
 
king daddyAuthor Commented:
restarted on both DNS servers. flushed dns on exchange server. forced connections through ESM and still queued. so aggravating. especially since it seems all of the partners email that domain.
0
 
king daddyAuthor Commented:
still can't send to bellsouth.net.

would setting up an SMTP connector allow the emails to be sent? if so, anything I should look out for when setting it up? I am going off of these directions:

http://support.microsoft.com/kb/265293

http://www.msexchange.org/tutorials/configuring-smtp-connector.html

thanks
0
 
Alan HardistyCo-OwnerCommented:
It should - but they might not make it to the destination via your ISP, but they stand a better chance.

Nothing to look out for - just specify the problem domains on the Scope tab.
0
 
king daddyAuthor Commented:
thanks. didn't work though. tried unfreezing and forcing. all queued emails moved from the original queue entry to another one that showed it was now going through an SMTP connector. Should I have configured for use DNS or forward through smart host? if smart host, what should I enter? I used DNS.
0
 
Alan HardistyCo-OwnerCommented:
You should configure it to use a smarthost and the usual one is your ISP's mail server (either their IP Address wrapped in square brackets [ ] or their Fully Qualified Domain Name mail.ispdomain.com).
0
 
king daddyAuthor Commented:
thanks. keep getting an error stating that I need to enter a valid IP address or a server name. I am entering the SMTP server sent to me by TW telecom a while back. I do not have an IP address. I did use brackets. SMTP server is relay.mail.twtelecom.net but exchange won't accept it.
0
 
Alan HardistyCo-OwnerCommented:
Just enter relay.mail.twtelecom.net - brackets are only used on IP Addresses.
0
 
king daddyAuthor Commented:
ha! was just about to post. found some screen shots and figured that out. queue shows a green check and no messages for the problematic domain. I think it worked! will update as people send to that domain.

thanks
0
 
Alan HardistyCo-OwnerCommented:
Well - they have left your server and will hopefully get to their destination.  Fingers crossed.
0
 
king daddyAuthor Commented:
one user confirmed their recipient received the email they sent minutes ago.
0
 
Alan HardistyCo-OwnerCommented:
:) - Excellent.  That's good news.
0
 
king daddyAuthor Commented:
seems to be working. thanks a lot.
0
 
king daddyAuthor Commented:
setting up the SMTP connector using an ISP mail server worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.