Windows 7 tries to login to Administrator Account each time and doesn't show my user account

This is a problem with Windows 7, Home Premium, 32 bit

Normally when I boot up I get a screen showing the two user accounts available on my machine.  Clicking on one allows me to enter the password, then I'm in.
However, recently the machine started booting straight into the Administrator account, which didn't have a password set. The only way to get into my normal account was to log off from the Admin Account.  I'd then get the choice of Admin or Other.  Clicking on other I had to enter the name of my main user account (Colin) and the password.
I managed to stop windows going straight into Admin by setting a password on it. So now on bootup I get a "Password entered was incorrect" error and it takes my to the screen showing the Admin account with a picture, and "other" with a blank box.  I tried deleting the other account but I still get "Other" as the option instead of my account name.

How do I get my Account to show again, so I can log straight in without entering the username?

I've checked some other related posts and some people have suggested editing the registry [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList].  However, I don't have a profile list folder at all.  Although I do have a Default file under the Windows NT folder next level up, with a value not set.  Could this be the problem?

Full marks awarded for a solution because I can't find anything on the internet with a fix for my situation.

Thanks
colin_thamesAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
Enter

control userpasswords2

either from a command prompt or from search bar, there you should be able to disable the automatic logon.

After that I'd do a thorough scan of the system with malwarebytes etc....
0
AnuroopsunddCommented:
1.Press the Windows key + R on your keyboard to launch the “Run” dialog box.
2.Type in control userpasswords2
3.Press Enter. The User Accounts window will display.
4.check the option “Users must enter a user name and password to use this computer”
5.Click “OK”
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Run5kCommented:
For future reference, while control userpasswords2 will still work on a Windows 7 machine you can also use the command netplwiz to reach the same destination.
0
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

colin_thamesAuthor Commented:
Thanks guys, worked like a charm, and for some reason the Administrator account doesn't come up anymore.
Rindi: I tried typing 'control passwords2' into the search bar but it didn't work.  Has to be in Run.  Unfortunately I didn't then know what to do.
Anuroopsundd: yours is the most complete solution, especially the tip to check the "Users must enter a username and password to use this computer".  I'd previously unchecked this on someone else's advice that I found on the internet.  Your advice was key.
Run5k: thanks, that's useful advice about 'netplwiz'.  This instruction works in the search bar or in Run mode.
0
rindiCommented:
I would still thoroughly check the System for Malware, as normally an autologon to the builtin Administrator's Account doesn't happen automatically. Either someone fiddled with your PC while you weren't on the premises, or you have received some malicious software that has either changed the logon and enabled the Administrator account, or a tool has allowed a hacker to gain access to your PC and change it's behavior.
0
colin_thamesAuthor Commented:
Thanks rindi. I've done a scan with Malwarebytes and all fine.  I suspect the problem happened because of my fiddling.  Whether it was because I had added a picture to my user account or something else I shall never know.

Thanks again for your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.