Solved

Open File - Security Warning problem with files and applications on mapped drive

Posted on 2012-04-04
4
892 Views
Last Modified: 2013-03-28
I keep getting this message:

"Open File - Security Warning

The publisher could not be verified. Are you sure you want to run this software?
Name: M:\application.exe
Publisher: Unknown Publisher
Type: Application
From: M:\application.exe"

the only options are to run or cancel

If i choose run the program runs without issue, however we don't want to have to do that.

I have tried a variety of solutions but haven't been able to resolve. I have tried adding the server that the file is hosted on to both the trusted sites and intranet zones but it doesn't make a difference. The only thing that kind of gets me to a solution is to go into the Internet Zone and choose custom level and under "Launching applications and unsafe files" choosing "enable (not secure)" . When I do this, I stop getting the prompt but I start getting a general warning from Internet Explorer saying "Your security settings put your computer at risk". I have tried changing this setting in both the Intranet Zone and the Trusted Sites zone but it doesn't make a difference.

Its almost as if I am unable to successfully add the local server to the local Intranet Zone or Trusted Sites zones successfully. Its like IE still thinks the server is in the Internet Zone no matter what I do.

I have tried adding it to the Trusted Sites/Intranet Zone using IP address, UNC path, wildcard, drive mapping with domain suffix and several others. None seem to make a difference. Any help I could get with this would be greatly appreciated.

Also, the OS of the machine is Windows 7 64 bit and the OS of the server is Windows 2008 R2.
0
Comment
Question by:Rob Sanders
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 10

Accepted Solution

by:
CSI-Windows_com earned 500 total points
ID: 37808255
Set the environment variable SEE_MASK_NOZONECHECKS to 1.

Be careful - if you do this for the entire computer, it turns off these safety checks for everything.
0
 
LVL 1

Author Comment

by:Rob Sanders
ID: 37808265
How do I not do it for the entire computer?
0
 
LVL 10

Expert Comment

by:CSI-Windows_com
ID: 37808308
You could write a .CMD to run it:

RunApplication.cmd:
SET SEE_MASK_NOZONECHECKS=1
M:\application.exe
0
 
LVL 1

Author Comment

by:Rob Sanders
ID: 37814237
That seems to have fixed the problem. Thanks for the help.
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
While working, an annoying popup showing below will come and we cannot cancel or close it form the screen. The error message will come again and again.
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum editing capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

687 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question