windows 7 same workgroup can't see xp machine

I have a new or reformatted machine that has Windows 7 pro 64 bit that cannot see xp machines and the xp machine can see, but cannot access.  I have home group off set to work.  network discovery on, file and print sharing on, public folder sharing on, password protection off, use user accounts and pw to connect, same username and password on each of the machines,  etc.  I can ping and i can access from xp machines if i use the ip of the Windows 7.  They are on DHCP.  please help.
sunnyflagirlAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

danielmarkoCommented:
Do you have a hardware firewall?

If you do then you can disable your windows 7 firewall and sharing should work.

If you do not have a hareware firewall then you need to enable file sharing in the Windows 7 firewall.

On thing to note is if they are not in the same work group you might have to login using a longer name.

For example assuming that:
your user account name is Pete and it is an account with permissions on both computers
the XP computer name is Georgescomputer and
the Windows 7 computer is Sallyscomputer.
The share on Sallyscomputer is call win7share and
the share on Georgescomputer is called winxp share.

Now you might have to use the credentials
            UN:  Sallyscomputer\pete
            PW:  whatever it is on Sallyscomputer even if you are on the
                      Georgescomputer computer trying access the share on Sallyscomputer .
0
sunnyflagirlAuthor Commented:
no hardware firewall, just windows firewall and symantec.  i disabled symantec, but still showing in windows firewall that it is controlled by symantec.  if i double click on it it was ask if i want symantec to run it or windows.  So not sure about that.  

file sharing is enabled in advanced sharing settings.  not sure where to set within windows firewall or if this is what you are talking about.

both machines are on the same workgroup.  

i don't have it setup where a username and pw is needed to access the shares?  so not sure where i would enter in computername\user to access.  the weird thing is i can access shares by ip and path name.  i just can't using windows 7 computer name then path.  

i can see the computer in xp, but can't access and in windows can't see the xp machine
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Darr247Commented:
If you want to see the XP machines in Vista's and Win7's network map, there is a hotfix you can request.
You can download the hotfix for XP SP2, but you have to request the fix for SP3 because microsoft forgot to include it in the rollup.

LLTD HotFix request - http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=922120&kbln=en-us

KB article - http://support.microsoft.com/KB/922120
0
sunnyflagirlAuthor Commented:
i did change a setting in symantec to "allow ip traffic" seems to be working now.  thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.