getting the message bash: lsmod: command not found

hi ,

i am working on RhEL server and almost every command i type i get
bash : command not found

i did

# bash

tried and nothing

i did

# PATH = /sbin/bash


any ideas ?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

c_hocklandAuthor Commented:
i am sorry , i menat


and no luck
The PATH variable setting is not correct. Did you try to logout / login again. Try to source ~/.profile or ~/.bash_profile with command

. ~/.profile


. ~/.bash_profile

Please note the dot and space in the above commands

Then see what you get when you run

echo $PATH

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Patrick TallaricoDecision Support and Systems AnalystCommented:
Check this out and see what you PATH environment variable is looking at.
Ensure Business Longevity with As-A-Service

Using the as-a-service approach for your business model allows you to grow your revenue stream with new practice areas, without forcing you to part ways with existing clients just because they don’t fit the mold of your new service offerings.

Gerwin Jansen, EE MVETopic Advisor Commented:
Try setting your path like this:

export PATH

Then try one of your commands.
c_hocklandAuthor Commented:
i did and i got he following

[h80613@ussef301 proc]$ ~/.bash_profile
bash: /home/h80613/.bash_profile: Permission denied

do i need to be added to sudo group ?
did you try to source the .bash_profile as shown above?
c_hocklandAuthor Commented:
[h80613@ussef301 proc]$ pATH=/usr/local/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin
[h80613@ussef301 proc]$ export pATH
[h80613@ussef301 proc]$ lsmod
bash: lsmod: command not found
please note that you have a typo in pATH it should be PATH
c_hocklandAuthor Commented:
yes , u r right . I typed it correclty and it worked.
you may add the commands to ~/.profile or ~/.bash_profile
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.