Solved

Remote Desktop Unable to Connect

Posted on 2012-04-04
15
680 Views
Last Modified: 2012-04-04
Hello,

I have a computer running Windows 7 x64.  It is a member of a domain using Active Directory.  When trying to access it using Remote Desktop I am getting the generic:

"Remote Desktop can't connect to the remote computer for one of the reasons:

1)Remote access to the server is not enabled
2)The remote computer is turned off
3)The remote computer is not available on the network
..."

I have "Allowed connections from computer running any version of remote desktop"
I have completely disabled windows firewall as the computer is behind a sonicwall firewall.  I have also made sure the remote desktop services are all running.  I also disabled the antivirus, although I don't think this is an issue because the other computers I remote into are all running the same antivirus.

I am trying to connect from another computer on the same network so it should not be going through the sonicwall. I have made sure I have the correct name of the computer and even tried using the ip address.  I can see the computer on the network.

There are several other computers on the network I remote into and it works fine.  And I have tried to remote into it using several different computers, including the server.  

FYI: I don't think it matters, but the server is running Windows Server 2008 R2.

Thank You
0
Comment
Question by:Kurt_BroszEngineering
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 2
  • +2
15 Comments
 
LVL 21

Expert Comment

by:motnahp00
ID: 37808906
Check your user rights assignments and listening port.
0
 

Author Comment

by:Kurt_BroszEngineering
ID: 37808927
Under the user rights assignments Remote Desktop users are allowed, and there is no one under the Deny log through remote desktop services.  

I attached a photo of the listening ports.
Listening-Ports.PNG
0
 
LVL 16

Expert Comment

by:Raymond Peng
ID: 37808943
on that machine - can you verify if it has the latest windows updates / service packs?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Kurt_BroszEngineering
ID: 37808958
I just checked for updates.  There are only three optional updates needed for our printer.  Service Pack 1 is installed.
0
 
LVL 16

Expert Comment

by:Raymond Peng
ID: 37808982
Did you say you could remote into it from other computers?

HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\
fDenyTSConnection

is that set to 0?
0
 

Author Comment

by:Kurt_BroszEngineering
ID: 37808991
No, I cannot remote into it from any computer on the network.  I can remote into other computers on the network.
0
 

Author Comment

by:Kurt_BroszEngineering
ID: 37809003
Also, I do not have the registry directory:

HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\
fDenyTSConnection

I do not have the: fDenyTSConnection folder
0
 
LVL 33

Expert Comment

by:digitap
ID: 37809117
Is it running any antivirus software that might be blocking RDP connectivity using its own firewall component?
0
 
LVL 33

Expert Comment

by:digitap
ID: 37809119
And, when you say same network, the two hosts are on the same subnet?
0
 

Author Comment

by:Kurt_BroszEngineering
ID: 37809127
No on the antivirus, I have it completely disabled.  And yes, they are on the same subnet.
0
 
LVL 33

Expert Comment

by:digitap
ID: 37809140
That's bizarre. With the firewall allowance of RDC, re-enable the firewall. By the way, how did you disable the firewall? I think that Windows 7 might ignore requests if the firewall service is stopped.
0
 
LVL 33

Expert Comment

by:digitap
ID: 37809150
Also, if enabled, you should be able to run a netstat -a from the command line and see that your device is listening on port 3389.
0
 

Author Comment

by:Kurt_BroszEngineering
ID: 37809201
I think I found the problem.  The computer does not seem to be listening on port 3389.  So how do I add that?
0
 
LVL 3

Accepted Solution

by:
gnemi earned 500 total points
ID: 37809321
Restart the RDP service.

Also, check in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber for the assigned port number.
0
 
LVL 33

Expert Comment

by:digitap
ID: 37809421
Glad to help.
0

Featured Post

Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you upgrade from Windows 8 to 8.1 or to Windows 10 or if you are like me you are on the Insider Program you may find yourself with many 450MB recovery partitions.  With a traditional disk that may not be a problem but with relatively smaller SS…
Use of TCL script on Cisco devices:  - create file and merge it with running configuration to apply configuration changes
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Suggested Courses

628 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question