Solved

Wordpress Template Tags not being replaced after moving servers

Posted on 2012-04-04
4
352 Views
Last Modified: 2012-04-10
I moved a wordpress website from one server to another.  I basically copied all of the files to the new server, exported the database and imported it in the new server.

I can now access the home page, but none of the menu items or links work (they lead to 404 errors when clicked) and images are not displayed.  Upon viewing the source code of the page, I can see all of the php template tags are still in the html.  They have not been replaced as they should be.

The database appears to have been migrated.  I did it twice to be sure.  Same with the files.  I copied them twice.

I'm running it on IIS 7.5 using MySQL.  I tried a fresh install of wordpress to make sure I had IIS configured properly and it worked just fine.
0
Comment
Question by:totalgolfnetwork
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 3

Expert Comment

by:gnemi
ID: 37809288
Check your logs for any php errors and make sure php is installed correctly with a phpinfo page.
0
 

Author Comment

by:totalgolfnetwork
ID: 37812612
That all seems to check out.  

I did narrow it down though to a custom theme.  If I switch to a default theme, the problem doesn't exist.  The odd thing is, I migrated a second site and had the exact problem.  The custom theme caused a problem, but the default themes do not.  There is a difference though.  In the second site, the first few template tags were replaced, but all of the rest were not.  

On the existing linux server, the custom themes work fine.  It is just on the IIS server that they do not.
0
 

Accepted Solution

by:
totalgolfnetwork earned 0 total points
ID: 37815069
Well, I figured out the solution to my problem.  The custom skin designer had used short open php tags everywhere.  PHP for IIS disables parsing of short tags by default.  You have to configure PHP for IIS to enable short open tags.
0
 

Author Closing Comment

by:totalgolfnetwork
ID: 37826828
I solved the problem.
0

Featured Post

DevOps Toolchain Recommendations

Read this Gartner Research Note and discover how your IT organization can automate and optimize DevOps processes using a toolchain architecture.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Wordpress and Wufoo 1 40
Length of for loop to be dynamic 2 33
Exchange OWA website Redirection 7 48
WordPress navigation menus: how to change color when clicked 10 22
I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
Nothing in an HTTP request can be trusted, including HTTP headers and form data.  A form token is a tool that can be used to guard against request forgeries (CSRF).  This article shows an improved approach to form tokens, making it more difficult to…
The purpose of this video is to demonstrate how to prevent comment spam on a WordPress Website. This will be demonstrated using a Windows 8 PC. Plugin Akismet will be used. Go to your WordPress login page. This will look like the following: myw…
The viewer will learn how to create and use a small PHP class to apply a watermark to an image. This video shows the viewer the setup for the PHP watermark as well as important coding language. Continue to Part 2 to learn the core code used in creat…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question