Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 883
  • Last Modified:

apache port 80 busy

Hi all,

I cannot get apache to start. It says port 80 Busy.
Many posts have suggested skype to be causing this issue. I do not have a skype installed on my PC.
In the command windows when i did a netstat -aon,  i see that port 80 is being used by a PID 4 which is a system Process.
I used netstat -abno which says it cannot obtain ownership information for port 80.


How do i get this working?
Thanksapache-error.docx
0
rowternet
Asked:
rowternet
  • 2
  • 2
1 Solution
 
papalalaCommented:
Is there any chance you have other web server installed? For example IIS? If yes, try to open windows components/features and uninstall it (Internet information Services).

You can also change its settings to other port: IIS > Web Server > select the server > sites > Default Web Site > Bindings > change port 80 to something else.
0
 
hintcoCommented:
Try port 8080
:)
0
 
rowternetAuthor Commented:
Hi papalala, hintco

I have IIS installed on this PC.
I tried to change the port that apache listens to from the apache->conf->httpdconf

#Listen 0.0.0.0:8080
#Listen [::]:8080
Listen 8080

It seems to be running now.
Thanks
0
 
hintcoCommented:
Ok, I'm glad that's run for u.
please accept the solution & close this question.
0
 
rowternetAuthor Commented:
Changing port fixed my Issue.
Thanks
0

Featured Post

Learn Veeam advantages over legacy backup

Every day, more and more legacy backup customers switch to Veeam. Technologies designed for the client-server era cannot restore any IT service running in the hybrid cloud within seconds. Learn top Veeam advantages over legacy backup and get Veeam for the price of your renewal

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now