?
Solved

Connect to OWA (Exchange 2010 - TMG) using Blackberry Phone

Posted on 2012-04-05
22
Medium Priority
?
2,409 Views
Last Modified: 2013-05-02
Hi All,

I have Exchange 2010 standard server migrated from Exchange 2003. All settings are ok. My OWA is published with TMG 2010 standard. I have access to OWA from external clients with no problem.
We need to configure email client in blackberry phone, but with no success. I have this message : " Cannot log in. Verify your email address, user name and password. If the error persists, contact domain.com, "

My Settings in Blackberry :

Email address : user@domain.com
Password : my AD password
Web Access URL : https://my.mail.com (without /owa)
User name : domain\username
Mailbox Name : my AD user name

OWA Authentication in Exchange 2010 : Basic Authentication
Web Listener Authentication in TMG 2010 : HTTP Authentication (Basic) - Windows (Active Directory)
OWA Publish Rule in TMG 2010 (Authentication Delegation) :  Basic Authentication

Please help me to find my mistake . Whats wrong in my configuration?
0
Comment
Question by:Tamooz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 13
  • 7
  • 2
22 Comments
 
LVL 13

Expert Comment

by:lauchangkwang
ID: 37809874
Did you try Mailbox name = user@domain.com ??
0
 

Author Comment

by:Tamooz
ID: 37809891
Yes, now and still cannot log in.
0
 

Author Comment

by:Tamooz
ID: 37809894
May be it's because Basic Authentication?
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 13

Expert Comment

by:lauchangkwang
ID: 37809947
Just to double confirm, when the time you said you are able to access OWA with no problem, is that using the link https://my.mail.com or https://my.mail.com/owa ?? If with owa, try to put the same link under Web Access URL and see whether it works.
0
 

Author Comment

by:Tamooz
ID: 37809951
It's https://my.mail.com/owa. Still cannot log in.
0
 
LVL 9

Expert Comment

by:Lance_P
ID: 37810344
https://www.testexchangeconnectivity.com/

Run the connectivity tests here and ensure that all pass. If not, then the site will guide you with what you can do to resolve your issues.
0
 

Author Comment

by:Tamooz
ID: 37810367
Exchange Web Services synchronization, notification, availability, and Automatic Replies (OOF).

Not all of the tests of Exchange Web Services tasks completed.

Test Steps

Ensuring that the test mailbox folder is empty and accessible.

ExRCA couldn't confirm that the folder is accessible and empty.

Additional Details
Exception details:
Message: The request failed. The remote server returned an error: (403) Forbidden.
Type: Microsoft.Exchange.WebServices.Data.ServiceRequestException
Stack trace:
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.GetEwsHttpWebResponse(IEwsHttpWebRequest request)
 at Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest`1.Execute()
 at Microsoft.Exchange.WebServices.Data.ExchangeService.BindToFolder[TFolder](FolderId folderId, PropertySet propertySet)
 at Microsoft.Exchange.Tools.ExRca.Tests.EnsureEmptyFolderTest.PerformTestReally()
Exception details:
Message: The remote server returned an error: (403) Forbidden.
Type: System.Net.WebException
Stack trace:
 at System.Net.HttpWebRequest.GetResponse()
 at Microsoft.Exchange.WebServices.Data.EwsHttpWebRequest.Microsoft.Exchange.WebServices.Data.IEwsHttpWebRequest.GetResponse()
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.GetEwsHttpWebResponse(IEwsHttpWebRequest request)
0
 
LVL 9

Expert Comment

by:Lance_P
ID: 37810396
I believe that you used an account which has emails in it which is why you see the above. You need to have a dummy mailbox with no emails in it to run that test

What happens when you run

Exchange ActiveSync
Outlook Autodiscover

Let us know. Try to click on the links that are provided to fix those issues if you get any.
0
 

Author Comment

by:Tamooz
ID: 37810424
Account with no emails :

Additional Details
Exception details:
Message: The request failed. The remote server returned an error: (403) Forbidden.
Type: Microsoft.Exchange.WebServices.Data.ServiceRequestException
Stack trace:
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.GetEwsHttpWebResponse(IEwsHttpWebRequest request)
 at Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest`1.Execute()
 at Microsoft.Exchange.WebServices.Data.ExchangeService.BindToFolder[TFolder](FolderId folderId, PropertySet propertySet)
 at Microsoft.Exchange.Tools.ExRca.Tests.EnsureEmptyFolderTest.PerformTestReally()
Exception details:
Message: The remote server returned an error: (403) Forbidden.
Type: System.Net.WebException
Stack trace:
 at System.Net.HttpWebRequest.GetResponse()
 at Microsoft.Exchange.WebServices.Data.EwsHttpWebRequest.Microsoft.Exchange.WebServices.Data.IEwsHttpWebRequest.GetResponse()
 at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.GetEwsHttpWebResponse(IEwsHttpWebRequest request

My Autodiscover and activesync is not published
0
 
LVL 9

Expert Comment

by:Lance_P
ID: 37810443
You need to publish active sync for Devices like  iPhones etc to connect. Unless you are just using the browser. And autodiscover is to make it easier for these devices.

For Laptops etc, you are using OWA which is web based. which is OK not to publish activesync

For BB I use BES. Ill check for BB's. Are you using BIS?
0
 

Author Comment

by:Tamooz
ID: 37810459
ExRCA is testing Exchange ActiveSync.
Exchange ActiveSync was tested successfully.

Now trying to create mail in blackberry
0
 

Author Comment

by:Tamooz
ID: 37810469
cannot log in.
May be it's because my published address of exchange is different from my prymary exchange domain?
My email address : user@x.com
Published Exchange 2010 address : https://mail.y.com
0
 
LVL 9

Expert Comment

by:Lance_P
ID: 37810483
Published Exchange 2010 address : https://mail.y.com

As long as you can set everything manually it should be OK.

Server settings etc.

You do have a Data package with your BB right? Are you aware if your telephone company requires you to pay extra for mail services? Some countries do.
0
 

Author Comment

by:Tamooz
ID: 37810495
My phone is ok. It's was worked with no errors before migration to Exchange 2010. In Exchange 2003 was Exchange-FronEnd Server, here (in Exchange 2010) i have OWA published with TMG 2010.
0
 

Author Comment

by:Tamooz
ID: 37810504
by the way, i successfully configured POP3 mail account in my blackberry. It's may be solution for me now, but its interesting why my OWA not working with blackberry.
0
 
LVL 9

Expert Comment

by:Lance_P
ID: 37810542
0
 
LVL 9

Expert Comment

by:Lance_P
ID: 37810551
Get-webservicesvirtualdirectory | set-webservicesvirtualdirectory –basicauthentication:$true
0
 
LVL 9

Expert Comment

by:Lance_P
ID: 37810555
0
 

Author Comment

by:Tamooz
ID: 37810565
I've seen this command before also this discuss (http://www.experts-exchange.com/Software/Internet_Email/Email/Q_25343975.html), but this did not solve my problem.
0
 

Accepted Solution

by:
Tamooz earned 0 total points
ID: 37860013
Hi All,

Thank you all for answers and help, but i'm alredy finde the solution.
The solution was to publish with OWA in TMG service EWS. Without this service blackberry can't verify your account in exchange. We must to verify that Exchange Web Services is turned on and accessible on port 80 (HTTP) or port 443 (HTTPS) of the Exchange Server. To check if Exchange Web Services is turned on, visit one of the following Internet addresses:
http://<maildomain>/EWS/Exchange.asmx
https://<maildomain>/EWS/Exchange.asmx
(for example, https://mail.microsoft.com/EWS/Exchange.asmx)
If Exchange Web Services is turned on and functioning correctly, the web address should display a XML page after the user credentials have been entered.

For publish EWS service you need to :
a) Open properties your OWA publish rule
b) Go to the "Paths" Tab
c) Click "Add", type /EWS/* and click OK
e) Click "Test Rule" just for verify that everything is ok

After that try to reconfig your Internet Mail Account in Blackberry. It's must to be OK.
0
 

Author Closing Comment

by:Tamooz
ID: 37879944
Good Silution!
0
 

Author Comment

by:Tamooz
ID: 39131003
Very good solution!
It's helped for me too.
Thanks!!!!
0

Featured Post

New benefit for Premium Members - Upgrade now!

Ready to get started with anonymous questions today? It's easy! Learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
I don't pretend to be an expert at this, but I have found a few things that are useful. I hope that sharing them here will help others, so they will not have to face some rather hard choices. Since I felt this to be a topic of enough importance and…
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question