• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 630
  • Last Modified:

Install jommla 2.5 on a Windows Server 2008 and use SQL server 2008

Hi there,
Although i think is possible i think i got stuck help would be much appreciated!
I'm able to see the joomla installation instruction and everything which is half of way but when i go to select the database only mySql is the only option that shows on the database drop down. I have tried so many way s on how to make my SQL database option to show but it does no want to work. Can you experts give some pointer or tell me how to do it? I try to locate my php.ini but i wasn't able to find it windows Server does not shows me where the file is and i did a search and it came back with the plesk information.
I'm working on a dedicated server out in the internet and i have full control over help would be much appreciated
-COHFL
0
COHFL
Asked:
COHFL
  • 4
  • 2
1 Solution
 
tobywestonCommented:
Php usually gets installed into C:\php. The php.ini file will be in there. Within that file there should be the following lines:

extension=php_sqlsrv_53_ts_vc9.dll
extension=php_pdo_sqlsrv_53_nts_vc9.dll

Open in new window


If they are not there, add them in with the rest of the extensions.

You will also need to make sure the MS SQL Drivers for PHP are installed.

This can be downloaded from Microsoft Drivers for PHP for SQL Server
0
 
COHFLAuthor Commented:
I did that but once i enable the dll the site does not respond and throws an error im wonder if i need to move the dll to an EXT folder or something?
do you know
0
 
COHFLAuthor Commented:
Run SQLSRV20.EXE
- When prompted, enter the path to the PHP extensions directory

whats that directory can i find it suing phpinfo()?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
COHFLAuthor Commented:
ok this might help pin point the problem

i go to IIS Manager and look a my site  under IIS there is an option that reads PHP Manager once i click on it all sort of options do show up. I go all the way to the bottom of the page and click on ENABLE OR DISABLE AN EXTENSION once the PHP Extension do load up i look for: extension=php_sqlsrv_53_ts_vc9.dll right click and enable them extension=php_pdo_sqlsrv_53_nts_vc9.dll right click and enable.

Once all this is enable i restart IIS and my server shows a 500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed error.

I go back to ISS click on my site virtual directory click on Content View and right click on index.php and select browse and this is what i get:

HTTP Error 500.0 - Internal Server Error
C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP5\php-cgi.exe - The FastCGI process exited unexpectedly

I hope this helps!
0
 
tobywestonCommented:
Can you try moving the dll to C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP5\ext and trying again.

The php.ini file should be in there as well, is that where you saw the "extension=" lines?

The following registry key should tell you where the php.ini file is as well.

HKEY_LOCAL_MACHINE\SOFTWARE\PHP\IniFilePath
0
 
COHFLAuthor Commented:
I think i found the problem since i was trying i left the 5.2 and 2.3 dll on the same directory this cause the problem once i delete the unnecessary dlls everything worked =)
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now