[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 585
  • Last Modified:

iPhones will not connect to Exchange Server on 3G or 4G

I have a company who has been using Exchange Server on their iPhone's for almost a year. Something has changed last weekend and now no one can send/receive E-Mails from exchange over the AT&T 3G or 4G networks. It will work over a Wi-Fi connection. My server is Windows Small Business Server 2011. I've tried removing the account and setting it back up. Any ideas what could have changed?
0
chriswolf
Asked:
chriswolf
  • 5
  • 3
  • 2
  • +1
1 Solution
 
Alan HardistyCommented:
Please check on https://testexchangeconnectivity.com to see if the test passes (Exchange Activesync) and if it does, it sounds like a DNS issue with your Airtime provider and may resolve itself in 24 hours (hopefully).
0
 
chriswolfAuthor Commented:
The test does fail saying that it can't validate the certificate name.
0
 
Alan HardistyCommented:
Ah - so did the certificate run out on the server and not get renewed?

SBS 2011 installs a 1 year cert as standard - and I always buy a SAN / UCC cert for 3 years whenever I install SBS 2011, so your cert may have expired or something else has happened to the cert.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
chriswolfAuthor Commented:
I'm checking with GoDaddy now about the certificate. Thanks!
0
 
hdmillerCommented:
Try this:

Open AD
Right click on user...properties
security tab
Click Advanced
Check the "Include inheritable permissions from this object's parent"

Wait a few mins and see if it connects.  I've not researched why this works, but anytime someone gets a new device I have to do this.  Obviously I only have a few users lol.
0
 
chriswolfAuthor Commented:
I checked with GoDaddy and my SSL certificate is active but the Exchange Active Sync test  still fails. hdmiller, I tried your idea with no luck. :(
0
 
Alan HardistyCommented:
Can you please post the results of the test showing the failure.

Thanks
0
 
Paul_C_HartleyCommented:
Has the certificate been renewed since the problem started.

It may be that the certificate expired and was automatically renewed and you have simply not installed the new certificate on the server.

likewise, are the real world DNS records on GoDaddy still pointing in the correct direction and are there valid records for the host names you are using?

When you say that they work on WiFi, are they working on WiFi on the local network on which the exchange server is located or are you using an entirely external WiFi network?
0
 
chriswolfAuthor Commented:
It will work on any external wi-fi. The certificate doesn't expire for a few months. Nothing has changed on the DNS records that I can see.
0
 
Paul_C_HartleyCommented:
It does sound an awful lot like an AT&T issue then as the phone should not be connecting to your server in any way that is different over 3/4G compared with public WiFi

Has there been any change in the data usage package you get from AT&T in recent weeks?

If you have a fixed IP for the server, have you tried simply using the IP address of the server rather than the FQDN and will it work with SSL turned off on the phone?
0
 
chriswolfAuthor Commented:
Using the server IP seems to have worked! Thanks.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now