installing mycrypt on ubuntu running on a virtual server

Hi guys i need to install mycrypt on a virtual server running Linux 2.6.38-11-server

I have SSH access only and i have tried using:

sudo apt-get install php5-mcrypt
 sudo /etc/init.d/apache2 restart

but i get:

:~# apt-get install php5-mcrypt /etc/init.d/apache2 restart
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package php5-mcrypt

this is on a fasthosts virtual server and im not sure what todo next?
firstnetsupportAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

larsrohrCommented:
Try an update first:
 apt-get update
 apt-get install php5-mcrypt

If that doesn't work, please show us the output of:
 lsb_release -a
and the contents of /etc/apt/sources.list
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
firstnetsupportAuthor Commented:
that seemed to work, my web application is saying that The mcrypt module is not configured to load with PHP. Please review the instructions for enabling mcrypt in the PHP manual.

they are pointing me towards the following link

http://us.php.net/manual/en/mcrypt.installation.php

how do i find my php.ini file using ssh? and furthermore how to i edit it?
0
larsrohrCommented:
I think you may just need to enable the module with:
 sudo a2enmod php5-mcrypt
0
larsrohrCommented:
Or possibly just restarting apache.
 sudo /etc/init.d/apache2 restart
0
firstnetsupportAuthor Commented:
Thanks for your help on this one its now working like a dream...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.