Classic ASP & IIS 7

Hello Experts,

I recently purchased a new PC with Win 7 Pro x64 / IIS 7 and still have my old machine with Win XP/ IIS 6 but I am having trouble running my Classic ASP code on IIS 7, I keep getting:

HTTP/1.1 New Application Failed

I arrived at this by going to http://localhost/Folder/subfolder/file.asp

Normally, under IIS 6 this works, but under IIS 7 do I need to do something special?
APD TorontoAsked:
Who is Participating?
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
Yes.  Classic is not enabled by default in IIS7.  See here:  One site said you had to install the 'asp.dll' also but I don't for sure.
gaurav05Connect With a Mentor Commented:
Hi ,

you need to install classic asp feature from add or remove windows components.

then use ASP.NET 1.1 application pool to run Classic asp application.
Let us know for further assistance.
APD TorontoAuthor Commented:
Still no luck.  

I went through the steps in the above link, same error.

I also ended up with these 2 files, which arre saved under my wwwroot.  

re my ApplicationHost.config, I tried setting location path="/" with hopes that it will affect all sub-folders of wwwroot.  I also tried location path="ABC", where ABC is a subfolder of wwwroot, and is conerted as an Application.

I've also tried removing IIS, deleting C:\Inetpub, and re-installing my IIS, the error persists.
APD TorontoAuthor Commented:
All is done via IIS MGR.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.