Solved

BGP Cisco to Mikrotik

Posted on 2012-04-06
4
1,484 Views
Last Modified: 2012-04-11
Hello,

I have been trying to replace our Cisco router, with mikrotik, everything else is working apart from the bgp session with our local exchange.

I have tried to configure bgp on mikrotik, get the routes but from lan i cannot ping the exchange router, but from mikrotik interface i can ping the bgp exchange router, looks like something is still wrong on mikrotik side. as if i put the cisco all is good.


This was on cisco on our side :-

router bgp 64530
no synchronization
bgp log-neighbor-changes
network 1.2.3.0 mask 255.255.255.0
network 1.2.4.0 mask 255.255.255.0
neighbor 1.2.3.2 remote-as 64530
neighbor 1.2.3.2 description iBGP with our router
neighbor 1.2.3.2 password
neighbor 1.2.3.2 version 4
neighbor 1.2.3.2 soft-reconfiguration inbound
neighbor 1.2.3.2 prefix-list in
neighbor 1.2.3.2 prefix-list out
neighbor 1.2.3.2 maximum-prefix 500
no auto-summary
!
ip route 1.2.3.0 255.255.255.0 Null0 250
ip route 1.2.4.0 255.255.255.0 Null0 250

#######################################
on the exchange side :

router bgp 64530
no synchronization
bgp log-neighbor-changes
neighbor 1.2.3.1 remote-as 64530
neighbor 1.2.3.1 description iBGP
neighbor 1.2.3.1 password
neighbor 1.2.3.1 version 4
neighbor 1.2.3.1 next-hop-self
neighbor 1.2.3.1 soft-reconfiguration inbound
neighbor 1.2.3.1 prefix-list in
neighbor 1.2.3.1 prefix-list out
neighbor 1.2.3.1 maximum-prefix 20
no auto-summary


Thanks Lot for the help
0
Comment
Question by:skywalker7
  • 2
4 Comments
 
LVL 28

Expert Comment

by:Jan Springer
ID: 37815929
Can you export the your bgp config from the MT?
0
 
LVL 1

Accepted Solution

by:
skywalker7 earned 0 total points
ID: 37816375
We went back to cisco at the moment and will work with this at a later date.

Many thanks for looking.
0
 
LVL 17

Expert Comment

by:TimotiSt
ID: 37818875
The BGP password is a Cisco-only feature, as far as i know. Not sure if the Mikrotik supports it.

Tamas
0
 
LVL 1

Author Closing Comment

by:skywalker7
ID: 37831671
We not using the mikrotik for bgp any longer.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
SSL RA VPN 7 104
How to use a IP block on cisco 877 3 42
Quality settings for cisco routers 8 53
configure ASA Vlan Interface 14 46
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
This article is a step by step guide on how to create a basic PTP link using Ubiquiti airOS devices. This guide can be used on the following Ubiquiti AirMAX devices. Nanostation, Bullets, AirBridge, Nanobeam, NanoBridge to name a few. Please review …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

896 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now