Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3303
  • Last Modified:

The Module DLL D:\Microsoft\Exchange Server\V14\Bin\kerbauth.dll failed to load. The data is the error

Hi,
 
I keep receiving an error message in the Event Logs for Exchange 2010:

The Module DLL D:\Microsoft\Exchange Server\V14\Bin\kerbauth.dll failed to load. The data is the error.
 
Event ID: 2280 - IIS-W3SVC-WP
 
OWA is working.

In IIS- HTTP Redirect is Disabled On the Default Website.
0
dp1985
Asked:
dp1985
  • 5
  • 3
1 Solution
 
AnuroopsunddCommented:
seems path for your path is incorrect...
can you check the actual path of the file kerbauth.dll

ones you find the file copy the path and put in the below file.
C:\Windows\System32\inetsrv\config\applicationHost.config

in the file search for below line and put the correct path
<add name=”kerbauth” image=”c:\ExchangeServer\V14\Bin\kerbauth.dll” />

ones changes are made save the file, the restart IIS by giving below command
IISRESET /NOFORCE
0
 
dp1985Author Commented:
On my exchange server Kerbauth.dll is located D:\Microsoft\Exchange Server\V14\Bin\kerbauth.dll

There is not Microsoft Folder on the C Drive
0
 
AnuroopsunddCommented:
Ok.can you confirm the path is same in application host.config file... And there is no typo...
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
dp1985Author Commented:
Yes, This is exactly what I have in the applicationhost.config
<add name="kerbauth" image="D:\Microsoft\Exchange Server\V14\Bin\kerbauth.dll" />
0
 
AnuroopsunddCommented:
1. Remote PowerShell uses Kerberos to authenticate the user connecting. IIS implements this Kerberos authentication method via a native module. In IIS Manager, if you go to the PowerShell Virtual Directory and then look at the Modules, you should see Kerbauth listed as a Native Module, with the dll location pointing to C:\Program Files\Microsoft\Exchange Server\v14\Bin\kerbauth.dll. If the Kerbauth module shows up as a Managed module instead of Native, or if the Kerbauth module has been loaded on the Default Web Site level (instead of, or in addition to, the PowerShell virtual directory), you can experience this issue. To correct this, make sure that the Kerbauth module is not enabled on the Default Web Site, but is only enabled on the PowerShell virtual directory. The entry type of "Local" indicates that the Kerbauth module was enabled directly on this level, and not inherited from a parent.

http://blogs.technet.com/b/exchange/archive/2010/02/04/3409289.aspx
0
 
dp1985Author Commented:
1) Kerbauth is only applied to the powershell with the module type=Native.
2) Kerbauth is not applied to the Default Website.
3) There is no C:\Program Files\Microsoft Folder nor C:\Microsoft There is only a D:\Microsoft folders
0
 
dp1985Author Commented:
I had an Exchange tech review this issue. I was given the option of either to open a ticket with Microsoft or re-Installed Exchange.
0
 
dp1985Author Commented:
Because this solution resolved it
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now