Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cannot complete the install because of a conflicting dependency

Posted on 2012-04-06
1
Medium Priority
?
744 Views
Last Modified: 2012-04-10
In trying to export an Eclipse product I get the error below:

I am not sure what is the problem since all the plugin.xml in the project show version 1.0.0 and not 0.0.0

It runs well with the run configuration but when I tried to export I get this error.

Any idea how to fix this?

!SESSION 2012-04-05 20:56:17.503 -----------------------------------------------
eclipse.buildId=M20120208-0800
java.version=1.6.0_16
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_CA
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -clean

!ENTRY org.eclipse.pde.core 4 0 2012-04-05 21:02:04.810
!MESSAGE  Cannot complete the install because of a conflicting dependency.
!SUBENTRY 1 org.eclipse.pde.core 4 0 2012-04-05 21:02:04.810
!MESSAGE  Software being installed: K 1.0.0.201204052101 (org.xtext.example.k.product.product 1.0.0.201204052101)
!SUBENTRY 1 org.eclipse.pde.core 4 0 2012-04-05 21:02:04.810
!MESSAGE  Software currently installed: K 0.0.0 (org.xtext.example.k.product.product 0.0.0)
!SUBENTRY 1 org.eclipse.pde.core 4 0 2012-04-05 21:02:04.810
!MESSAGE  Only one of the following can be installed at once:
!SUBENTRY 1 org.eclipse.pde.core 4 0 2012-04-05 21:02:04.810
!MESSAGE  Cannot satisfy dependency:
!SUBENTRY 1 org.eclipse.pde.core 4 0 2012-04-05 21:02:04.810
!MESSAGE  Cannot satisfy dependency:
!SUBENTRY 1 org.eclipse.pde.core 4 0 2012-04-05 21:02:04.810
!MESSAGE  Cannot satisfy dependency:
!SUBENTRY 1 org.eclipse.pde.core 4 0 2012-04-05 21:02:04.810
!MESSAGE  Cannot satisfy dependency:
0
Comment
Question by:nnifco
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 12

Accepted Solution

by:
Sharon Seth earned 1500 total points
ID: 37817303
Seems  plugin development environment is being added twice to the export
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Programmer's Notepad is, one of the best free text editing tools available, simply because the developers appear to have second-guessed every weird problem or issue a programmer is likely to run into. One of these problems is selecting and deleti…
Update (December 2011): Since this article was published, the things have changed for good for Android native developers. The Sequoyah Project (http://www.eclipse.org/sequoyah/) automates most of the tasks discussed in this article. You can even fin…
The viewer will learn how to use and create keystrokes in Netbeans IDE 8.0 for Windows.
The viewer will learn how to synchronize PHP projects with a remote server in NetBeans IDE 8.0 for Windows.

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question