Solved

Exchange outlook error

Posted on 2012-04-06
5
682 Views
Last Modified: 2012-04-21
Hi ,

User is facing the below error while login the mail through outlook ( RPC over http).

"There is a problem with the proxy security certificate.

Outlook is unable to connect to the Proxy server

webmail.abc.com ( error code 20)"

There is no problem with webmail access.

while I checking the certificate, it is showing IIS certificate invaild ( it is expired).

So I Renew the certificate by the new-exchange certifcate command , but still same problem.

We are not using any external trusted certificate, is there any possibility to expired any SAN CA certifcate, so , please suggest how do in created SAN root ( CA ) certificate & export in two CAS serevr which are in LNB.

We are using Windows Server 2008 NLB for cas Server.

It is urgent , please suggest.
0
Comment
Question by:padas6
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 12

Expert Comment

by:Deepu Chowdary
ID: 37817488
I assume that u have used
Get- ExchangeCertificate -Thumbprint '01234567890123456789' | New-ExchangeCertificate
Have you restarted the MSExchangeTransport Service ??
0
 
LVL 17

Expert Comment

by:WORKS2011
ID: 37817665
Here are the commands needed to renew a self signed cert.  

1 Get-ExchangeCertificate -domain "domain" | fl
2 Get-ExchangeCertificate -thumbprint "2FB28F5075EFE9B30A8F8458DED0A191542HUG6J" | New-ExchangeCertificate
3 Confirm Overwrite existing default SMTP certificate
4 Enable-ExchangeCertificate -thumbprint "FB5AECA6B39816F02B3245BD1D95394458741HU7" -services IIS

If you've done these already then you probably just need to restart iis, at a command prompt type iisreset.
0
 

Accepted Solution

by:
padas6 earned 0 total points
ID: 37818778
I have already done the same, it is problem with SAN certificate.

Please let me know why we required self SAN certificate even though we are generating a new exchange certificate through the command prompt.
0
 
LVL 9

Expert Comment

by:ash007
ID: 37822669
Please create a new self signed SAN certificate as it has entry for autodiscover.domain.com which is required for RPC over https.

Also make sure we have proper certificate for NLB url in IIS manager
0
 

Author Closing Comment

by:padas6
ID: 37875057
The problem was self SAN certificate. After create the certificate, submitted to local CA server then enable the certificate in both the Hub Transport Server.
0

Featured Post

Salesforce Has Never Been Easier

Improve and reinforce salesforce training & adoption using WalkMe's digital adoption platform. Start saving on costly employee training by creating fast intuitive Walk-Thrus for Salesforce. Claim your Free Account Now

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question