?
Solved

Microsoft Office Dialog Box Warning

Posted on 2012-04-06
10
Medium Priority
?
1,346 Views
Last Modified: 2015-03-19
I'm running Windows Vista Business.

I have a small database in Access that allows me to search for files and provide me a hyperlink to the document for easy access.  The problem (annoyance) is that when I click on the hyperlink I get a dialog box from Microsoft Office that says:

"Opening \\[file path and name].  Some files can contain viruses or otherwise be harmful to your computer.  It is important to be certain that this file isfrom a trustworth source.  Would you like to open this file?"

I select "Ok" and then it opens just fine in IrfanView (an application I use to view the files).

How can I make the warning go away?

thanks,
Darin
0
Comment
Question by:DarinOBrien
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 9

Assisted Solution

by:AdrienneSperber
AdrienneSperber earned 400 total points
ID: 37817383
Click Start, and then click Run.
In the Open dialog box, type regedit, and then click OK.

Notes
You have to modify only one of these registry subkeys. You do not have to modify both.
If the Security subkey already exists, go directly to step 6 after you select the Security subkey.
In Registry Editor, locate one of the following registry subkeys for 2007 Office:
HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\CommonHKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Common
Or, in Registry Editor, locate one of the following registry subkeys for Office 2010:
HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\CommonHKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Common
Click the registry subkey, point to New on the Edit menu, and then click Key.
Type Security, and then press Enter to name the key.
On the Edit menu, point to New, and then click DWORD Value.
Type DisableHyperlinkWarning, and then press Enter to name the entry.
In the right pane, right-click DisableHyperlinkWarning, and then click Modify.
In the Edit DWORD Value dialog box, click Decimal, and then type 1 or 0 under Value data.

Note A value of 0 enables the hyperlink warning message. A value of 1 disables the hyperlink warning message.
Click OK.
Exit Registry Editor.
0
 
LVL 97

Expert Comment

by:Experienced Member
ID: 37817389
It varies a bit by version, so below is a sample:

In Word 2010, go to Trust Center, Options, Trusted locations and check (select) Allow Trusted Locations.

As I say, this setting varies by version, so if you cannot find the Trust Center, let us know which Office Application and which Version.

The Office settings are by application (not Office General) and each application is treated differently. I am not sure how that may affect Iranview.

So if no effect, the next place would the Privacy and Security settings in Internet Explorer.

.... Thinkpads_User
0
 

Author Comment

by:DarinOBrien
ID: 37817829
TO: AdrienneSperber.  I tried creating the key as you described and set the value to 1 to disable the hyperlink message.  Unfortunately, I still get the message.

TO:  thinkpads_user.  I'm running a combination of Office apps including Access 2002 and Word 2002 and Word 2010.  I tried modifying the Word 2010 settings as you suggested above.  I don't see anything comparable in Word 2002 and Access 2002. Still getting the warning message.

thanks
darin
0
Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 97

Expert Comment

by:Experienced Member
ID: 37817870
Take a look in Internet Explorer, Tools, Internet Options, Security Settings. There are settings in there that affect downloads (from a link) and create prompts. Perhaps this is what you are seeing.

IE9-Security-Settings
You can also change these settings for the Trusted Zone as well, and you might turn Trusted Zone to very low or temporarily off to see.

I know in my case, I see these warnings and simply OK them as I would not want them disabled.  

.... Thinkpads_User
0
 

Author Comment

by:DarinOBrien
ID: 37818064
I found the Security Settings shown above and turned off all security modes.  I also tried changing the specific setting shown above.  Still no joy.

thanks,
darin
0
 
LVL 97

Accepted Solution

by:
Experienced Member earned 1600 total points
ID: 37818077
It may be something you have to live with. I have no idea how deep some of the security settings go, but my guess is very deep, given the grief we gave Microsoft over security.

Some of the settings for newer Office applications against a standard server setup can be adjusted so as not to warn. But this is in a totally trusted environment.

For hyperlinks (web links) into an application, the settings above are the only ones I know of.

... Thinkpads_User
0
 

Author Comment

by:DarinOBrien
ID: 37877781
It sounds like this is a problem I'll have to live with.  I'm not exactly sure how to handle the question at this point.  

Should I just "delete question"?

thanks,
darin
0
 

Author Closing Comment

by:DarinOBrien
ID: 38214922
I awarded points to clean up this open question.  The problem is one that can't be easily resolved.  Thanks to everyone who replied!
0
 
LVL 97

Expert Comment

by:Experienced Member
ID: 38214970
Thank you for following up. .... Thinkpads_User
0
 
LVL 1

Expert Comment

by:mystikal1000
ID: 40675743
Create/add the REG_DWORD type registry value “EditFlags” (with the value data "EditFlags"=dword:00010000) under the registry key location “HKCR\htmlfile_FullWindowEmbed\”

Worked for me.
0

Featured Post

2017 Webroot Threat Report

MSPs: Get the facts you need to protect your clients.
The 2017 Webroot Threat Report provides a uniquely insightful global view into the analysis and discoveries made by the Webroot® Threat Intelligence Platform to provide insights on key trends and risks as seen by our users.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This process allows computer passwords to be managed and secured without using LAPS. This is an improvement on an existing process, enhanced to store password encrypted, instead of clear-text files within SQL
What's worse than having your data encrypted by ransomware? Getting attacked by a so-called "wiper," which simply destroys the data and offers you no hope of ever seeing it again.
The viewer will learn how to create a normally distributed random variable in Excel, use a normal distribution to simulate the return on an investment over a period of years, Create a Monte Carlo simulation using a normal random variable, and calcul…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question