Missing network adapters

I have two, onboard NICs, Intel 82575s.  Device Manager shows Connection #3 and Connection #4.  It does not show the original devices, which are Connection #1 and Connection #2.  The present 3 and 4 "replaced" 1 and 2 and work fine, but really haven't replaced 1 and 2.  For example, I cannot rename 3 or 4.  I want to remove 3 and 4 so that 1 and 2 reappear.  I tried uninstalling the NICs 3 and 4, but they came back on reboot.  I attached a screen shot from Device Manager.
Clipboard01.png
sjw601Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

IT-Monkey-DaveCommented:
In Device Manager, go to View, and click on Show Hidden Devices.  Adapters 1 & 2 may show up but as disabled or missing.  Try deleting them.  That may cause 3 & 4 to change to 1 & 2, or you may be able to rename them after the phantom 1 & 2 have gone away.
Darius GhassemCommented:
Did you disable 1 and 2 in the systems BIOS? Once you have disabled in BIOS when you boot those should be gone. Once you have done that uninstall other network card then on reboot they should show 1 and 2.
sjw601Author Commented:
Thanks.  3 & 4 showed up, but no 1 or 2.
SolarWinds® Network Configuration Manager (NCM)

SolarWinds® Network Configuration Manager brings structure and peace of mind to configuration management. Bulk config deployment, automatic backups, change detection, vulnerability assessments, and config change templates reduce the time needed for repetitive tasks.

Darius GhassemCommented:
This is common when you have a PCI card in the system
sjw601Author Commented:
>Did you disable 1 and 2 in the systems BIOS?

The only option in the BIOS is to disable the NIC ROM.  Doing so did not resolve the issue.

>This is common when you have a PCI card in the system

Perhaps, but this issue presents on only one of several systems with the same config
Darius GhassemCommented:
Hmm. So, in the BIOS you don't have the option to disable the on board network card? Have you fully remove the new card out. disabled the other on board network cards? Do these on aboard network ports show in Device Manager still?
sjw601Author Commented:
>So, in the BIOS you don't have the option to disable the on board network card? Have you
>fully remove the new card out. disabled the other on board network cards? Do these on
>aboard network ports show in Device Manager still?

No, there is no option to disable the NICs.  There is no other network card in the system.  There is a video card (PCIe), 1394(b) card (PCI-32), and RAID controller (PCIe).
Darius GhassemCommented:
So, do the on board network ports show in Device Manager?
sjw601Author Commented:
Yes, as in my screen shot.
Darius GhassemCommented:
Alright maybe I read your post wrong. You aren't adding network cards you just have an with built-in network ports showing as 3 and 4, right?
sjw601Author Commented:
Yes.  There are only two onboard NICs.  At one time, they showed up properly as 1 and 2.  Now, they're 3 and 4.
Darius GhassemCommented:
Alright sorry I was confused then. Did you make any changes?

I see you have VM virtual adapters listed. How many physical network ports do you have on the server?
sjw601Author Commented:
There are two ports.
Darius GhassemCommented:
Do the other servers with same config have VMware installed? I'm wondering if these other VMWare adapters are causing the problem
sjw601Author Commented:
Yes.  Every machine has VMware.
Darius GhassemCommented:
Doesn't make sense. No changes to the system?

Can you remove VMWare adapters to see if that does anything?

The only other thing I can think of going through http://support.microsoft.com/kb/269155

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
IT-Monkey-DaveCommented:
I've seen this many times, can happen via removing and reinstalling the NIC drivers, or updating the drivers.  Let me take a look at our servers...
sjw601Author Commented:
Fixed!  I followed Method 1 in the link that you provided.  Then, the phantom NICs appeared in Device Manager.  I removed them and I removed the valis ones, too.  After reboot, only 1 and two appear.  Thanks!
Darius GhassemCommented:
I'm glad it is fixed. Thanks!
IT-Monkey-DaveCommented:
I'd forgotten that just clicking on Show Hidden Devices in Device Manager may not be adequate...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.