Access 2003 Slow on windows Vista and Window 7

We are currently Running SQL Server 2000 on a Windows Server 2003 server.  We use Access 2003 as a front end.  We have used Windows XP systems for the last 6 years and everything was running fine.  Except now that we bought two new systems (Windows 7) , access runs slow.  It it would take 1 seconds to to open a form on a Windows XP system, it takes almost 10 seconds to do it on Windows 7.  I also tested it on a Windows Vista system, and the same problem occurs.

Has anyone had this issue?

Thanks,
mfsrulesAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

als315Commented:
Read this thread:
http://social.msdn.microsoft.com/Forums/en/windowscompatibility/thread/f295994c-5812-4e46-8ac9-f05471d4dd54
There are two recommended solutions:
1. Add your server name to hosts file to prevent use of Windows Vista and 7 LLMNR protocol
2. Disable TCP autotuning
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mfsrulesAuthor Commented:
Yes.  That was one of the main issues.  By disabling LLMNR the speed has improved dramatically.  XP systems are still a little bit faster though.   If you don't want to read through the thread just follow these steps to disable the LLMNR protocol:

Modify Group Policy – Go to Search – Type GPEdit.msc – Enter – Navigate to the following and make sure Enabled is checked -

Computer Configuration\Administrative Templates\Network\DNS Client
\Turn off Multicast Name Resolution = Enabled

Thank you for your help and hope this helps other people who might be having the same issue.


***Update.  Windows 7 32 bit seems to work faster than the 64 bit version.  Also Windows 8 is slower than Windows 7
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Access

From novice to tech pro — start learning today.