Sql Login failed

Login failedHi,

I have issue when I try to login by SQL Authentication mode
I can open the database and browse the tables, but I can not login by  SQL Authentication mode.
Windows server 2008
Sql 2008
Who is Participating?
Deepak ChauhanConnect With a Mentor SQL Server DBACommented:
It is seem like port error Please try to connect to sql server with port name

eg: servername\instancename, 1433

if you are using windows group user like domainname\username then sql server will  connect in windows authentication model
not in sql authentication mode

If you are using sql server user then it will be connect in sql authentication model

and another thing please check port in sql sever configuration and endpoint also
•Right click on instance (IE SQLServer2008)
•Select "Properties"
•Select "Security" option
•Change "Server authentication" to "SQL Server and Windows Authentication mode"
•Restart the SQLServer service
•Right click on instance
•Click "Restart"

samprgAuthor Commented:
It is "SQL Server and Windows Authentication mode" already
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

Can you view the event logs and see if their are any errors their when you try to login.
are you trying to login using SQL account or machine/domain account?
samprgAuthor Commented:
I found this event log
AnuroopsunddConnect With a Mentor Commented:
Logon as a local administrator.

2. Stop the "SQL Server" service and run "C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\Binn\sqlservr.exe" -m" (as described in http://connect.microsoft.com/SQLServer/feedback/ViewFeedback.aspx?FeedbackID=353451 to start SQL Server in Local Only mode.

3. Logon to SSMS from the server itself - no password required.

4. Add your own domain account as a Login, with sysadm server role.

5. Restart the SQL Server service

Norman MainaConnect With a Mentor Commented:
Hey -BEFORE you try the ABOVE :::

Do this:
Verify that the windows user logged in and accessing SQL Server has the necessary permissions in SQL SERVER by going to the security tab and checking if the windows user is already setup.

windows users will appear in this format : domain\username
Felix LevenConnect With a Mentor Senior System and DatabaseadministratorCommented:
There are different reasons for this event. If the mentioned solutions fail, check

And post what comes closest to your environment.
Patricia Siu-Lai HoConnect With a Mentor Commented:
Hi Samprg,

Have you checked your login page, the path pointing to connect to your database is correct?

Patricia / pslh
samprgAuthor Commented:
I have tried to login by "sa" gives me error
memoryI tried again , I got same error "Login failed......" th above
Felix LevenSenior System and DatabaseadministratorCommented:
Try to disable shared memory provide in sql configuration manager. Seems to be a Problem in Virtual SQL Servers.
samprgAuthor Commented:
I did and same error "Login failed....."
samprgAuthor Commented:
Thank you
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.